summary refs log tree commit diff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-10-12 20:07:31 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-10-13 22:50:45 +0200
commit29f632220c02c3e880f390123699fd4c19ebdb27 (patch)
tree246c8da2d29a273ef1a2d483b34af1d09f73a810 /gnu/packages/music.scm
parent32536f00588fb46a81beedad406d5cc071898322 (diff)
downloadguix-29f632220c02c3e880f390123699fd4c19ebdb27.tar.gz
gnu: Add gx-super-fuzz-lv2.
* gnu/packages/music.scm (gx-super-fuzz-lv2): New variable.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 12d60b5922..4f8d14a133 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2169,3 +2169,25 @@ simulation of the Hyperion Fuzz pedal."))))
 simulation modelled after the Voodoo Lab SuperFuzz pedal.  It's basically a
 Bosstone circuit, followed by the tone control of the FoxToneMachine in
 parallel with a DarkBooster, followed by a volume control."))))
+
+(define-public gx-super-fuzz-lv2
+  (let ((commit "9800354caeb4082a64ca55b2daa9a9a1f79b8c21")
+        (revision "1"))
+    (package (inherit gx-guvnor-lv2)
+      (name "gx-super-fuzz-lv2")
+      (version (string-append "0-" revision "." (string-take commit 9)))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/brummer10/GxSuperFuzz.lv2")
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "1jclp53p01h94cpx17wm4765r7klbr41g7bvq87l53qwlrgkc7a9"))
+                (file-name (string-append name "-" version "-checkout"))))
+      (home-page "https://github.com/brummer10/GxSuperFuzz.lv2")
+      (synopsis "Fuzz effect modelled after the UniVox SuperFuzz")
+      (description "This package provides the LV2 plugin \"GxVoodooFuzz\", an
+analog simulation of the UniVox SuperFuzz pedal.  In this simulation the trim
+pot, which is usualy in the housing, is exposed as a control parameter.  It
+adjusts the amount of harmonics."))))