summary refs log tree commit diff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-04-03 00:13:06 +0200
committerLudovic Courtès <ludo@gnu.org>2017-04-03 00:13:06 +0200
commit2a0d5de5a9decd785b22dafa69aae5320231f1b7 (patch)
tree6c532e278025fb46a94f4cb3c3a68063b7011fe1 /gnu/packages/music.scm
parent41f6d18fb6ae7adebe72793c625ad4574991fa6d (diff)
parent245575eaf33801753ac8290e077c4397b2568540 (diff)
downloadguix-2a0d5de5a9decd785b22dafa69aae5320231f1b7.tar.gz
Merge branch 'core-updates'
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 2196a6a7ea..6f42160f77 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -906,6 +906,7 @@ add_library( rapidjson INTERFACE IMPORTED )"))
            (lambda* (#:key inputs #:allow-other-keys)
              ;; Link with required static libraries, because we're not
              ;; using the bundled version of withershins.
+             ;; Also add pthread for fixing a linker error.
              (substitute* "source/build/CMakeLists.txt"
                (("withershins" line)
                 (string-append line "\n"
@@ -914,6 +915,7 @@ add_library( rapidjson INTERFACE IMPORTED )"))
                                (assoc-ref inputs "libiberty")
                                "/lib/libiberty.a\n"
                                "dl\n"
+                               "pthread\n"
                                "z\n")))
              #t)))))
     (inputs
@@ -1239,6 +1241,13 @@ mixing, FFT scopes, MIDI automation and full scriptability in Scheme.")
                (substitute* "bristol/Makefile.in"
                  (("-msse -mfpmath=sse") "")))
              #t))
+         ;; alsa-lib 1.1.x no longer provides iatomic.h.  That's okay because
+         ;; bristol actually doesn't use it.
+         (add-after 'unpack 'do-not-use-alsa-iatomic
+           (lambda _
+             (substitute* "libbristolaudio/audioEngineJack.c"
+               (("#include <alsa/iatomic.h>") ""))
+             #t))
          ;; We know that Bristol has been linked with JACK and we don't have
          ;; ldd, so we can just skip this check.
          (add-after 'unpack 'do-not-grep-for-jack