summary refs log tree commit diff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-12-16 08:34:48 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-12-16 09:01:56 +0100
commit6ac8c78c89b6a59916ece24364b824df83e4df5c (patch)
treec45cee6262e2e080b743d7784539fb4e2ab3b097 /gnu/packages/music.scm
parent4b359532570b8cd75241c46a4d325d66427a7821 (diff)
downloadguix-6ac8c78c89b6a59916ece24364b824df83e4df5c.tar.gz
gnu: gx-guvnor-lv2: Download sources from git.
* gnu/packages/music.scm (gx-guvnor-lv2)[source]: Download from git.
[arguments]: Decouple "install" target from build target.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index e4fb4dcfa2..fe118d42bb 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2677,13 +2677,14 @@ standard MIDI file with the csvmidi program.")
     (name "gx-guvnor-lv2")
     (version "0.1")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/brummer10/GxGuvnor.lv2/"
-                                  "archive/v" version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/brummer10/GxGuvnor.lv2.git")
+                    (commit (string-append "v" version))))
+              (file-name (string-append name "-" version "-checkout"))
               (sha256
                (base32
-                "0rnfvrvs8qmmldyfmx4llyly33zp68448gx40ywdwj42x0mam92p"))))
+                "1wa5070j40p7f0b3kr259pzm99xb6cf2badr2capayjvgayd6gnm"))))
     (build-system gnu-build-system)
     (arguments
      `(;; The check target is used only to output a warning.
@@ -2695,7 +2696,8 @@ standard MIDI file with the csvmidi program.")
          (replace 'configure
            (lambda _
              (substitute* "Makefile"
-               (("INSTALL_DIR = .*") "INSTALL_DIR=/lib/lv2\n"))
+               (("INSTALL_DIR = .*") "INSTALL_DIR=/lib/lv2\n")
+               (("install : all") "install :"))
              #t)))))
     (inputs
      `(("lv2" ,lv2)))