summary refs log tree commit diff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorSimon Streit <simon@netpanic.org>2021-09-02 13:50:53 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-09-04 14:53:34 +0200
commitab12354c0a37fb2a232935f8c5ce388d040241e2 (patch)
treeb661d8e23aacc1006ec3b953253ee22f451ee873 /gnu/packages/music.scm
parent9f543674ff0f2f178b656597fef24e834635d60b (diff)
downloadguix-ab12354c0a37fb2a232935f8c5ce388d040241e2.tar.gz
gnu: python-mediafile: Update to 0.7.0.
Remove patch. It is now included in upstream release.

* gnu/packages/music.scm (python-mediafile): Update to 0.7.0.
* gnu/packages/patches/python-mediafile-wavpack.patch: Delete patch.
* gnu/local.mk: Deregister it.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 6236703f48..82c9242cd3 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -41,6 +41,7 @@
 ;;; Copyright © 2021 Rovanion Luckey <rovanion.luckey@gmail.com>
 ;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
 ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3604,20 +3605,18 @@ streams on an individual packet/page level.")
 (define-public python-mediafile
   (package
     (name "python-mediafile")
-    (version "0.6.0")
+    (version "0.8.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "mediafile" version))
-       (patches (search-patches "python-mediafile-wavpack.patch"))
        (sha256
         (base32
-         "0jmsp3f57xj35ayp8b6didk85nxgl3viw34s5px3l5dwgc055yx3"))))
+         "0ipb001j19s9wvssmrj8wz0nrkbl0k3zr3dgzyp1bd9cjc6vklnp"))))
     (build-system python-build-system)
     (propagated-inputs
      `(("python-mutagen" ,python-mutagen)
-       ("python-six" ,python-six)
-       ("python-tox" ,python-tox)))
+       ("python-six" ,python-six)))
     (home-page "https://github.com/beetbox/mediafile")
     (synopsis "Read and write audio file tags")
     (description