summary refs log tree commit diff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-03-30 10:11:56 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-03-30 10:35:53 +0200
commitc3913fac57c557ba5ebc98c646f75c7000ab8aa7 (patch)
tree590c244d79b7f235c7c65b7a80422e81e6b90ff4 /gnu/packages/music.scm
parente32f8dad9468f07f608fc0e2f83b9533d054a186 (diff)
downloadguix-c3913fac57c557ba5ebc98c646f75c7000ab8aa7.tar.gz
gnu: powertabeditor: Link with pthread.
* gnu/packages/music.scm (powertabeditor)[arguments]: Link with "-lpthread" to
fix build with GCC 5.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 198c6f1fed..3946c3a646 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -906,6 +906,7 @@ add_library( rapidjson INTERFACE IMPORTED )"))
            (lambda* (#:key inputs #:allow-other-keys)
              ;; Link with required static libraries, because we're not
              ;; using the bundled version of withershins.
+             ;; Also add pthread for fixing a linker error.
              (substitute* "source/build/CMakeLists.txt"
                (("withershins" line)
                 (string-append line "\n"
@@ -914,6 +915,7 @@ add_library( rapidjson INTERFACE IMPORTED )"))
                                (assoc-ref inputs "libiberty")
                                "/lib/libiberty.a\n"
                                "dl\n"
+                               "pthread\n"
                                "z\n")))
              #t)))))
     (inputs