summary refs log tree commit diff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2020-10-02 18:19:00 +0100
committerMathieu Othacehe <othacehe@gnu.org>2020-10-06 11:39:57 +0200
commitf7c031d15565f9858afbfd9f92e264186880959b (patch)
tree13e86c213e0309058f2e737f375a0bd2bc30f0a9 /gnu/packages/music.scm
parent8416f0f26cf2904de23ac20fba5d122cf86f9bf0 (diff)
downloadguix-f7c031d15565f9858afbfd9f92e264186880959b.tar.gz
gnu: zrythm: Update to 1.0.0-alpha.3.0.1.
* gnu/packages/music.scm (zrythm): Update to 1.0.0-alpha.3.0.1.
[arguments]: Explicitly enable RtMidi support in #:configure-flags.
<phases>: Remove xdg-open patch (no longer needed).

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm15
1 files changed, 4 insertions, 11 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 879d90b241..1434af9788 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5538,7 +5538,7 @@ and as an LV2 plugin.")
     ;; distros to make necessary changes to integrate the software into the
     ;; distribution.
     (name "zrythm")
-    (version "0.8.911")
+    (version "1.0.0-alpha.3.0.1")
     (source
       (origin
         (method url-fetch)
@@ -5546,7 +5546,7 @@ and as an LV2 plugin.")
                             version ".tar.xz"))
         (sha256
           (base32
-            "1xyp70sjc2k5pfdqbwqa988v86da0rmmyl8ry86bqv4ja80sc6g9"))))
+            "06025367x08y4g9grhcn35bk1dsrpgm04c8l8j50i3p49dl3s1n0"))))
    (build-system meson-build-system)
    (arguments
     `(#:glib-or-gtk? #t
@@ -5558,15 +5558,8 @@ and as an LV2 plugin.")
         "-Dgraphviz=enabled" ; for exporting routing graphs
         "-Dguile=enabled" ; for Guile scripting
         "-Djack=enabled" ; for JACK audio/MIDI backend
-        "-Dsdl=enabled") ; for SDL audio backend (which uses ALSA)
-      #:phases
-      (modify-phases %standard-phases
-        (add-after 'unpack 'patch-xdg-open
-          (lambda _
-            (substitute* "src/utils/io.c"
-                         (("OPEN_DIR_CMD")
-                          (string-append "\"" (which "xdg-open") "\"")))
-            #t)))))
+        "-Drtmidi=enabled" ; for RtMidi backend (ALSA sequencer)
+        "-Dsdl=enabled"))) ; for SDL audio backend (which uses ALSA)
    (inputs
     `(("alsa-lib" ,alsa-lib)
       ("jack" ,jack-1)