summary refs log tree commit diff
path: root/gnu/packages/musl.scm
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2016-08-03 16:44:40 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-08-13 11:31:39 +0200
commitce728f70e5ef8783a28652e382c2c9f61c7b4c06 (patch)
tree59b72b3e916aaa77f6af970ef984a7a2ea93780f /gnu/packages/musl.scm
parent2f82b53b94764908d71289968a464de26caf4a51 (diff)
downloadguix-ce728f70e5ef8783a28652e382c2c9f61c7b4c06.tar.gz
gnu: Add Musl.
* gnu/packages/musl.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/musl.scm')
-rw-r--r--gnu/packages/musl.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/musl.scm b/gnu/packages/musl.scm
new file mode 100644
index 0000000000..a96185a561
--- /dev/null
+++ b/gnu/packages/musl.scm
@@ -0,0 +1,50 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages musl)
+  #:use-module (guix download)
+  #:use-module (guix packages)
+  #:use-module (guix build-system gnu)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (gnu packages))
+
+(define-public musl
+  (package
+    (name "musl")
+    (version "1.1.15")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://www.musl-libc.org/releases/"
+                                  name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1ymhxkskivzph0q34zadwfglc5gyahqajm7chqqn2zraxv3lgr4p"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f  ; Musl has no tests
+       #:configure-flags
+       (list "--disable-gcc-wrapper")))
+    (synopsis "Small C standard library")
+    (description "musl is a simple and lightweight C standard library.  It
+strives to be correct in the sense of standards-conformance and safety.")
+    (home-page "http://www.musl-libc.org")
+    ;; Musl as a whole is released under the Expat license.  Parts of it are
+    ;; derived from various third-party projects that are released under
+    ;; non-copyleft licenses.  See the COPYRIGHT file for details.
+    (license license:expat)))