summary refs log tree commit diff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorStefan Reichoer <stefan@xsteve.at>2015-09-15 10:39:49 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-18 21:54:03 +0200
commit24a848c8e36e762968e6e2803a72ae570e9edbec (patch)
tree58efe9e199e78d06420e7624b55654b1db011a5b /gnu/packages/networking.scm
parent4f740b677a554595596031d80b46eae032eaafb0 (diff)
downloadguix-24a848c8e36e762968e6e2803a72ae570e9edbec.tar.gz
gnu: Add ifstatus.
* gnu/packages/networking.scm (ifstatus): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm43
1 files changed, 42 insertions, 1 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index dc139e28fe..08380b1f87 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2015 Stefan Reichör <stefan@xsteve.at>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -23,7 +24,8 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
-  #:use-module (gnu packages tls))
+  #:use-module (gnu packages tls)
+  #:use-module (gnu packages ncurses))
 
 (define-public miredo
   (package
@@ -146,3 +148,42 @@ receiving NDP messages.")
 auto-negotiation and checksum offload on many network devices, especially
 Ethernet devices.")
     (license license:gpl2)))
+
+(define-public ifstatus
+  (package
+    (name "ifstatus")
+    (version "1.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/ifstatus/ifstatus-v"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "045cbsq9ps32j24v8y5hpyqxnqn9mpaf3mgvirlhgpqyb9jsia0c"))
+              (modules '((guix build utils)))
+              (snippet
+               '(substitute* "Main.h"
+                  (("#include <stdio.h>")
+                   "#include <stdio.h>\n#include <stdlib.h>")))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:tests? #f                                ; no "check" target
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)             ; no configure script
+         (replace 'install
+                  (lambda* (#:key outputs #:allow-other-keys)
+                    (let* ((out (assoc-ref outputs "out"))
+                           (bin (string-append out "/bin")))
+                      (mkdir-p bin)
+                      (copy-file "ifstatus"
+                                 (string-append bin "/ifstatus"))))))))
+    (inputs `(("ncurses" ,ncurses)))
+    (home-page "http://ifstatus.sourceforge.net/graphic/index.html")
+    (synopsis "Text based network interface status monitor")
+    (description
+     "IFStatus is a simple, easy-to-use program for displaying commonly
+needed / wanted real-time traffic statistics of multiple network
+interfaces, with a simple and efficient view on the command line.  It is
+intended as a substitute for the PPPStatus and EthStatus projects.")
+    (license license:bsd-2)))