summary refs log tree commit diff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-09-10 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-09-10 02:00:00 +0200
commit477600f818d37e7fab99386370d36a67c962573e (patch)
tree05d053e0afd92c3de0c8138da6949f88af1ce93b /gnu/packages/networking.scm
parent521147d04c218186548b176ddd47a678ccf62d1d (diff)
downloadguix-477600f818d37e7fab99386370d36a67c962573e.tar.gz
gnu: httping: Update to 2.9.
* gnu/packages/networking.scm (httping): Update to 2.9.
[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 383f28e793..a36f8c3f65 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1928,15 +1928,16 @@ transmission protocol (SCTP) in a Go application.")
 (define-public httping
   (package
     (name "httping")
-    (version "2.5")
+    (version "2.9")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://www.vanheusden.com/httping/httping-"
-                           version ".tgz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/folkertvanheusden/HTTPing")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "1y7sbgkhgadmd93x1zafqc4yp26ssiv16ni5bbi9vmvvdl55m29y"))))
+        (base32 "1gbpirzih0zr93fm71scqjji9wwkfp64q8z36857blsngdfm6k38"))))
     (build-system gnu-build-system)
     (arguments
      (list #:make-flags