summary refs log tree commit diff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-09-07 23:24:02 +0800
committerMarius Bakke <marius@gnu.org>2023-09-08 18:53:47 +0800
commit51939d19c14bbc755417d4a4ef98e21fd1b6d690 (patch)
treeafa63ef15adabf48ac7302c524ef578093ef6f10 /gnu/packages/networking.scm
parent963abdf05de996f3f18133b8f06ab457ecdd1848 (diff)
downloadguix-51939d19c14bbc755417d4a4ef98e21fd1b6d690.tar.gz
gnu: iputils: Update to 20221126.
* gnu/packages/networking.scm (iputils): Update to 20221126.
[source](patches): Remove.
[arguments]: Remove obsolete phase.  Disable one new test.
[description]: Adjust for removed commands.
* gnu/packages/patches/iputils-libcap-compat.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm39
1 files changed, 12 insertions, 27 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index dd3c7485d0..1403bab363 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1564,35 +1564,25 @@ intended as a substitute for the PPPStatus and EthStatus projects.")
 (define-public iputils
   (package
     (name "iputils")
-    (version "20190709")
+    (version "20221126")
     (home-page "https://github.com/iputils/iputils")
     (source (origin
               (method git-fetch)
-              (uri (git-reference (url home-page)
-                                  (commit (string-append "s" version))))
+              (uri (git-reference (url home-page) (commit version)))
               (file-name (git-file-name name version))
-              (patches (search-patches "iputils-libcap-compat.patch"))
               (sha256
                (base32
-                "04bp4af15adp79ipxmiakfp0ij6hx5qam266flzbr94pr8z8l693"))))
+                "1qfdvr60mlwh5kr4p27wjknz1cvrwfi6iadh9ny45661v22i0njx"))))
     (build-system meson-build-system)
     (arguments
-     `(#:configure-flags '("-DBUILD_RARPD=true")
-       #:phases
+     `(#:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'fix-docbook-url
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let* ((docbook-xsl (assoc-ref inputs "docbook-xsl"))
-                    (uri (string-append docbook-xsl "/xml/xsl/docbook-xsl-"
-                                        ,(package-version docbook-xsl))))
-               (for-each
-                (lambda (file)
-                  (substitute* file
-                    (("http://docbook\\.sourceforge\\.net/release/xsl-ns/current")
-                     uri)))
-                (cons "doc/meson.build"
-                      (find-files "doc" "\\.xsl$")))
-               #t))))))
+         (add-after 'unpack 'disable-ping-test
+           (lambda _
+             ;; Disable ping test, as it requires root or raw socket capabilities.
+             (substitute* "test/meson.build"
+               (("if build_ping == true")
+                "if false")))))))
     (native-inputs
      `(("gettext" ,gettext-minimal)
        ("pkg-config" ,pkg-config)
@@ -1611,20 +1601,15 @@ configuration, troubleshooting, or servers.  Utilities included are:
 @item @command{arping}: Ping hosts using the @dfn{Address Resolution Protocol}.
 @item @command{clockdiff}: Compute time difference between network hosts
 using ICMP TSTAMP messages.
-@item @command{ninfod}: Daemon that responds to IPv6 Node Information Queries.
 @item @command{ping}: Use ICMP ECHO messages to measure round-trip delays
 and packet loss across network paths.
-@item @command{rarpd}: Answer RARP requests from clients.
-@item @command{rdisc}: Populate network routing tables with information from
-the ICMP router discovery protocol.
-@item @command{tftpd}: Trivial file transfer protocol server.
 @item @command{tracepath}: Trace network path to an IPv4 or IPv6 address and
 discover MTU along the way.
 @end itemize")
     ;; The various utilities are covered by different licenses, see LICENSE
     ;; for details.
-    (license (list license:gpl2+  ;arping, rarpd, tracepath
-                   license:bsd-3  ;clockdiff, ninfod, ping, tftpd
+    (license (list license:gpl2+        ;arping, tracepath
+                   license:bsd-3        ;clockdiff, ping
                    (license:non-copyleft
                     "https://spdx.org/licenses/Rdisc.html"
                     "Sun Microsystems license, see rdisc.c for details")))))