summary refs log tree commit diff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-10 23:32:37 +0200
committerMarius Bakke <marius@gnu.org>2022-09-11 19:43:15 +0200
commit8f78e9b0bc7ef3fa479527d87c6d11dd3b8be983 (patch)
treed2ecf2c855636ac60bbb53c3acc927c8bdf7928a /gnu/packages/networking.scm
parentd3a772d43dcc5ed20e1861b8d3797459ae21918a (diff)
downloadguix-8f78e9b0bc7ef3fa479527d87c6d11dd3b8be983.tar.gz
gnu: Open vSwitch: Remove input labels.
* gnu/packages/networking.scm (openvswitch)[native-inputs]: Remove labels.
[arguments]: Use SEARCH-INPUT-FILE instead of labels.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index b8d017c753..d43190a8d5 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2751,13 +2751,12 @@ procedure calls (RPCs).")
        (modify-phases %standard-phases
          (add-after 'unpack 'use-absolute-/bin/sh
            (lambda* (#:key inputs #:allow-other-keys)
-             (let* ((bash (assoc-ref inputs "bash-minimal")))
+             (let ((/bin/sh (search-input-file inputs "bin/sh")))
                (substitute* "ovsdb/ovsdb-server.c"
-                 (("/bin/sh") (string-append bash "/bin/sh"))))))
+                 (("/bin/sh") /bin/sh)))))
          (add-before 'check 'adjust-tests
            (lambda* (#:key inputs #:allow-other-keys)
-             (let* ((bash (assoc-ref inputs "bash-minimal"))
-                    (/bin/sh (string-append bash "/bin/sh")))
+             (let ((/bin/sh (search-input-file inputs "bin/sh")))
                (with-fluids ((%default-port-encoding "ISO-8859-1"))
                  (substitute* (find-files "tests" ".*(run|testsuite)$")
                    (("#! /bin/sh")
@@ -2794,13 +2793,14 @@ ps --no-header -p $1 -o state= | grep -qv '^Z$'"
                      "DBDIR=/tmp"
                      "install"))))))
     (native-inputs
-     `(("perl" ,perl)
-       ("pkg-config" ,pkg-config)
-       ("python" ,python-wrapper)
-       ;; for testing
-       ("bash" ,bash)                   ;for 'compgen'
-       ("procps" ,procps)
-       ("util-linux" ,util-linux)))
+     (list perl
+           pkg-config
+           python-wrapper
+
+           ;; For testing.
+           bash                         ;for 'compgen'
+           procps
+           util-linux))
     (inputs
      (list bash-minimal libcap-ng openssl))
     (synopsis "Virtual network switch")