summary refs log tree commit diff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-27 14:52:56 -0400
committerMark H Weaver <mhw@netris.org>2015-07-27 15:12:52 -0400
commita2b2aebea9ab67fe4c1462e26ff5164e371b66dd (patch)
treee34b07066ddb8845313f5646b5d62116dca92518 /gnu/packages/networking.scm
parent3dc8828f18d61e307d9482f9c3d4020b0457d7d1 (diff)
downloadguix-a2b2aebea9ab67fe4c1462e26ff5164e371b66dd.tar.gz
gnu: Add libndp.
* gnu/packages/networking.scm (libndp): New variable.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 717e6242be..70e02d6c7f 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -105,3 +106,23 @@ asynchronous message queues, multiple messaging patterns, message
 filtering (subscriptions), seamless access to multiple transport protocols and
 more.")
     (license license:lgpl3+)))
+
+(define-public libndp
+  (package
+    (name "libndp")
+    (version "1.5")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://libndp.org/files/"
+                                  name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "15f743hjc7yy2sv3hzvfc27s1gny4mh5aww59vn195fff2midwgs"))))
+    (build-system gnu-build-system)
+    (home-page "http://libndp.org/")
+    (synopsis "Library for Neighbor Discovery Protocol")
+    (description
+     "libndp contains a library which provides a wrapper for IPv6 Neighbor
+Discovery Protocol.  It also provides a tool named ndptool for sending and
+receiving NDP messages.")
+    (license license:lgpl2.1+)))