summary refs log tree commit diff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-10-01 16:21:38 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 11:00:06 +0000
commita7bc1c8dd3613793c715765abc3d2604dfbdbed3 (patch)
tree9dd66e902d2e855532bff7b2a32281cca35732bf /gnu/packages/networking.scm
parentd3d6e8b31a38becaab1196c3f311b7ef50221853 (diff)
downloadguix-a7bc1c8dd3613793c715765abc3d2604dfbdbed3.tar.gz
gnu: libproxy: Respect #:tests?.
* gnu/packages/networking.scm (libproxy)[arguments]<#:phases>{check}: Don't
  run the tests if the value for #:tests? is false.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index c426c95e71..d6a2b6bb6b 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2251,16 +2251,12 @@ sockets in Perl.")
      `(("dbus" ,dbus)
        ("zlib" ,zlib)))
     (arguments
-     `(#:phases
+     '(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           ;; TODO(core-updates): Make this unconditional.
-           ,(if (%current-target-system)
-                '(lambda* (#:key tests? #:allow-other-keys)
-                   (when tests?
-                     (invoke "ctest" "-E" "url-test")))
-                '(lambda _
-                   (invoke "ctest" "-E" "url-test")))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "ctest" "-E" "url-test")))))))
     (synopsis "Library providing automatic proxy configuration management")
     (description "Libproxy handles the details of HTTP/HTTPS proxy
 configuration for applications across all scenarios.  Applications using