summary refs log tree commit diff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-15 02:00:10 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:01 +0200
commitf9e20e979eda9df70fea4ee530231ebb9d1bad71 (patch)
tree557016ed6d99467c486e1b2045793a6a38fc4d2e /gnu/packages/networking.scm
parentf262ec40a5eb468e9ba62b5ad4f25e70c491a63c (diff)
downloadguix-f9e20e979eda9df70fea4ee530231ebb9d1bad71.tar.gz
gnu: aircrack-ng: Improve SMP performance.
* gnu/packages/networking.scm (aircrack-ng)[inputs]: Add hwloc:lib.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 9d19fbade9..0a1176da5b 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -116,6 +116,7 @@
   #:use-module (gnu packages linux)
   #:use-module (gnu packages lua)
   #:use-module (gnu packages kerberos)
+  #:use-module (gnu packages mpi)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages nettle)
   #:use-module (gnu packages openldap)
@@ -1875,7 +1876,8 @@ live network and disk I/O bandwidth monitor.")
     (native-inputs
      (list autoconf automake libtool pkg-config which))
     (inputs
-     (list libgcrypt
+     (list `(,hwloc "lib")              ; speed boost on SMP machines
+           libgcrypt
            libnl
            libpcap
            ethtool