summary refs log tree commit diff
path: root/gnu/packages/ninja.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-07-18 23:27:18 +0200
committerLudovic Courtès <ludo@gnu.org>2015-07-18 23:27:18 +0200
commit2e839545c7f363b50ae760c9b9c15da9e7619da9 (patch)
treeca2cb9147e50431b4e1fcd7626e2c50812c826ad /gnu/packages/ninja.scm
parentc5c4c4b437f977f4aaedb34a258cd94146c93d4d (diff)
downloadguix-2e839545c7f363b50ae760c9b9c15da9e7619da9.tar.gz
gnu: ninja: Do not report files with mtime = 0 as missing.
This is a followup to 47f315a.

* gnu/packages/patches/ninja-zero-mtime.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/ninja.scm (ninja)[source]: Reinstate 'patches' field and add
  this patch.
  [arguments]: Remove 'apply-ninja-tests.patch' phase.
Diffstat (limited to 'gnu/packages/ninja.scm')
-rw-r--r--gnu/packages/ninja.scm17
1 files changed, 3 insertions, 14 deletions
diff --git a/gnu/packages/ninja.scm b/gnu/packages/ninja.scm
index b55dd37e78..a0eb109bbb 100644
--- a/gnu/packages/ninja.scm
+++ b/gnu/packages/ninja.scm
@@ -23,7 +23,6 @@
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
-  #:use-module (gnu packages base)
   #:use-module (gnu packages python))
 
 (define-public ninja
@@ -38,23 +37,13 @@
               (sha256
                (base32
                 "1h3yfwcfl61v493vna6jia2fizh8rpig7qw2504cvkr6gid3p5bw"))
-              ;; XXX Ninja's build system doesn't cope well with zeroed
-              ;; time stamps in the source tree, so we must avoid using
-              ;; 'patch-and-repack'.
-              #; (patches (list (search-patch "ninja-tests.patch")))))
+              (patches (map search-patch
+                            '("ninja-zero-mtime.patch" "ninja-tests.patch")))))
     (build-system gnu-build-system)
-    (native-inputs `(("python" ,python-2)
-                     ("patch" ,patch)
-                     ("ninja-tests.patch" ,(search-patch "ninja-tests.patch"))))
+    (native-inputs `(("python" ,python-2)))
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (add-after
-          'unpack 'apply-ninja-tests.patch
-          ;; XXX Apply the patch here to avoid 'patch-and-repack'.  See above.
-          (lambda* (#:key inputs #:allow-other-keys)
-            (zero? (system* "patch" "--force" "-p1" "-i"
-                            (assoc-ref inputs "ninja-tests.patch")))))
          (replace
           'configure
           (lambda _