summary refs log tree commit diff
path: root/gnu/packages/node-xyz.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-01-08 03:42:15 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-09 02:07:16 +0100
commit12e05563695044649154ba51eef8acddc72797fe (patch)
treea62c273e160349f74e0cf268531f26abe42f06a2 /gnu/packages/node-xyz.scm
parente6ef40bef28b4439246b863f7d4b4c6bab780a34 (diff)
downloadguix-12e05563695044649154ba51eef8acddc72797fe.tar.gz
gnu: Add node-bindings.
* gnu/packages/node-xyz.scm (node-bindings): New variable.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/node-xyz.scm')
-rw-r--r--gnu/packages/node-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index f9a14c9d68..0e621a2e52 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -868,3 +868,28 @@ with SQLite3 databases.")
 URI to a file path.  It accepts a @code{file:} URI and returns a file path
 suitable for use with the @code{fs} module functions.")
     (license license:expat)))
+
+(define-public node-bindings
+  (package
+    (name "node-bindings")
+    (version "1.5.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/TooTallNate/node-bindings")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "100gp6kpjvd4j1dqnp0sbjr1hqx5mz7r61q9qy527jyhk9mj47wk"))))
+    (inputs
+     (list node-file-uri-to-path))
+    (build-system node-build-system)
+    (arguments
+     ;; there are no tests
+     `(#:tests? #f))
+    (home-page "https://github.com/TooTallNate/node-bindings")
+    (synopsis "Locate native addons")
+    (description "This package provides a helper module to locate native
+addons in a wide array of potential locations.")
+    (license license:expat)))