summary refs log tree commit diff
path: root/gnu/packages/node-xyz.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-01-08 03:42:17 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-09 02:07:16 +0100
commit517c988bcaca73a498c206d28e7b6b65f19cd54d (patch)
treece41ddde9a1bc4e668fb1452d0c0f2df6b028dc1 /gnu/packages/node-xyz.scm
parentdb82f64cf785474276283298ecb803a280b41091 (diff)
downloadguix-517c988bcaca73a498c206d28e7b6b65f19cd54d.tar.gz
gnu: Add node-ms.
* gnu/packages/node-xyz.scm (node-ms): New variable.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/node-xyz.scm')
-rw-r--r--gnu/packages/node-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index c4c88e8df2..b07e17d54c 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -922,3 +922,36 @@ code modules and getting stack traces when things go wrong.  If a
 @code{SIGSEGV} signal is raised, the module will print a native stack trace to
 both @file{stderr} and to a timestamped file.")
     (license license:bsd-3)))
+
+(define-public node-ms
+  (package
+    (name "node-ms")
+    (version "2.1.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/vercel/ms")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1l74kmmwffmzdz38lli0v5mdb9p9jmsjxpb48ncknqw2n74cgf08"))))
+    (build-system node-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'patch-dependencies 'delete-dependencies
+           (lambda args
+             (delete-dependencies `("eslint"
+                                    "expect.js"
+                                    "husky"
+                                    "lint-staged"
+                                    "mocha"
+                                    "prettier")))))
+       #:tests? #f))
+    (home-page "https://github.com/vercel/ms")
+    (synopsis "Convert time to milliseconds")
+    (description "Use this package to easily convert various time formats to
+milliseconds.  A number supplied as integer or string is returned as-is, while
+a string consisting of a number and a time unit is converted to milliseconds.")
+    (license license:expat)))