summary refs log tree commit diff
path: root/gnu/packages/node-xyz.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-01-08 03:42:26 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-09 02:07:17 +0100
commit5a621e83d854494630b61f9720e28a4aebf9c1df (patch)
tree940838d2fdae82f766680c97e1d130b2deafa422 /gnu/packages/node-xyz.scm
parentb27a772827325f038ff32912d523efe583e4f00e (diff)
downloadguix-5a621e83d854494630b61f9720e28a4aebf9c1df.tar.gz
gnu: Add node-serialport-parser-cctalk.
* gnu/packages/node-xyz.scm (node-serialport-parser-cctalk): New variable.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/node-xyz.scm')
-rw-r--r--gnu/packages/node-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 76874b12d0..1f2934432b 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -1197,3 +1197,26 @@ recommended high-level interface.
 Parsers are used to take raw binary data and transform them into usable
 messages.  This package provides @code{InterByteTimeout}, a parser that emits
 data if there is a pause between packets for the specified amount of time.")))
+
+(define-public node-serialport-parser-cctalk
+  (package
+    (inherit node-serialport-binding-abstract)
+    (name "node-serialport-parser-cctalk")
+    (version "9.2.4")
+    (inputs `())
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'chdir
+           (lambda args
+             (chdir "packages/parser-cctalk"))))
+       #:tests? #f))
+    (synopsis "Node SerialPort parser for the ccTalk protocol")
+    (description "Node SerialPort is a modular suite of Node.js packages for
+accessing serial ports.  The Guix package @code{node-serialport} provides the
+recommended high-level interface.
+
+Parsers are used to take raw binary data and transform them into usable
+messages.  This package provides @code{CCTalk}, which emits packets for the
+ccTalk protocol (an open standard for currency detectors) as they are
+received.")))