summary refs log tree commit diff
path: root/gnu/packages/node-xyz.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-01-08 03:42:02 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-09 02:07:13 +0100
commit8c83a9c7ea321654e6a9d48b7087243e898569ba (patch)
tree707036ae4916c5b6c93751dafe37a67c221a0aa0 /gnu/packages/node-xyz.scm
parentcdc47fb3ef80ddefdf959979f98e665e2c95b0ed (diff)
downloadguix-8c83a9c7ea321654e6a9d48b7087243e898569ba.tar.gz
gnu: node-wrappy: Use 'delete-dependencies'.
gnu/packages/node-xyz.scm (node-wrappy)[arguments]: Use
'delete-dependencies'.  Stop deleting the 'configure' phase.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/node-xyz.scm')
-rw-r--r--gnu/packages/node-xyz.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index e99cd27a14..e1ffdf978c 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -320,8 +320,9 @@ function with browser support.")
      '(#:tests? #f ; FIXME: Tests depend on node-tap
        #:phases
        (modify-phases %standard-phases
-         ;; The only dependency to check for is tap, which we don't have.
-         (delete 'configure))))
+         (add-after 'patch-dependencies 'delete-dependencies
+           (lambda args
+             (delete-dependencies '("tap")))))))
     (home-page "https://github.com/npm/wrappy")
     (synopsis "Callback wrapping utility")
     (description "@code{wrappy} is a utility for Node.js to wrap callbacks.")