summary refs log tree commit diff
path: root/gnu/packages/node-xyz.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-02-04 13:40:20 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-18 12:34:47 +0000
commitbd6c3acda26f5ba95dc8b3d47c9854d84bbc2c65 (patch)
tree988aeee589b6e11d55b89d5852b3a26d550926a2 /gnu/packages/node-xyz.scm
parentd41d3d8fb2d210a7d14e1e31092e3ebc068ecc92 (diff)
downloadguix-bd6c3acda26f5ba95dc8b3d47c9854d84bbc2c65.tar.gz
gnu: node-nan: Move package in alphabetical order.
* gnu/packages/node-xyz.scm (node-nan): Move package in alphabetical order.

Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/node-xyz.scm')
-rw-r--r--gnu/packages/node-xyz.scm78
1 files changed, 39 insertions, 39 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index bc8fd0fb69..250816c04a 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -487,6 +487,45 @@ random number generator.")
 Javascript.")
     (license license:expat)))
 
+(define-public node-nan
+  (package
+    (name "node-nan")
+    (version "2.15.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/nodejs/nan")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "18xslh9va5ld872scrp5y4251ax9s3c6qh0lnl1200lpzbsxy7yd"))))
+    (build-system node-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'patch-dependencies 'delete-dependencies
+           (lambda args
+             (delete-dependencies
+              '("bindings"
+                "commander"
+                "glob"
+                "request"
+                "node-gyp" ;; would be needed for tests
+                "tap"
+                "xtend")))))
+       ;; tests need tap and other dependencies
+       #:tests? #f))
+    (inputs
+     (list node-readable-stream))
+    (home-page "https://github.com/nodejs/nan")
+    (synopsis "Native Abstractions for Node.js")
+    (description "Native Abstractions for Node.js (``NaN'') provides a header
+file filled with macros and utilities for making add-on development for Node.js
+easier across versions.  The goal is to provide all logic necessary to develop
+native Node.js addons without having to inspect @code{NODE_MODULE_VERSION}.")
+    (license license:expat)))
+
 (define-public node-normalize-path
   (package
     (name "node-normalize-path")
@@ -979,45 +1018,6 @@ function with browser support.")
 particular cross-platform spellings of the PATH environment variable key.")
     (license license:expat)))
 
-(define-public node-nan
-  (package
-    (name "node-nan")
-    (version "2.15.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/nodejs/nan")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "18xslh9va5ld872scrp5y4251ax9s3c6qh0lnl1200lpzbsxy7yd"))))
-    (build-system node-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'patch-dependencies 'delete-dependencies
-           (lambda args
-             (delete-dependencies
-              '("bindings"
-                "commander"
-                "glob"
-                "request"
-                "node-gyp" ;; would be needed for tests
-                "tap"
-                "xtend")))))
-       ;; tests need tap and other dependencies
-       #:tests? #f))
-    (inputs
-     (list node-readable-stream))
-    (home-page "https://github.com/nodejs/nan")
-    (synopsis "Native Abstractions for Node.js")
-    (description "Native Abstractions for Node.js (``NaN'') provides a header
-file filled with macros and utilities for making add-on development for Node.js
-easier across versions.  The goal is to provide all logic necessary to develop
-native Node.js addons without having to inspect @code{NODE_MODULE_VERSION}.")
-    (license license:expat)))
-
 (define-public node-addon-api
   (package
     (name "node-addon-api")