summary refs log tree commit diff
path: root/gnu/packages/ntp.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-06-03 16:56:44 -0400
committerLeo Famulari <leo@famulari.name>2016-06-05 00:16:56 -0400
commit620ce2ef23326c40cd907f564483d133b0bedd07 (patch)
tree855a5764cf347568d10d64c43b1673b8f1bdadc1 /gnu/packages/ntp.scm
parent71cb237a7d98dafda7dfbb5f3ba7c68463310383 (diff)
downloadguix-620ce2ef23326c40cd907f564483d133b0bedd07.tar.gz
gnu: ntp: Add HTTPS URL.
This works around an HTTP -> HTTPS redirection.

* gnu/packages/ntp.scm (ntp)[source]: Add HTTPS URL.
Diffstat (limited to 'gnu/packages/ntp.scm')
-rw-r--r--gnu/packages/ntp.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index 4ae25450e8..8b4f53d4d3 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -42,10 +42,14 @@
    (version "4.2.8p7")
    (source (origin
 	    (method url-fetch)
-	    (uri (string-append
-                  "http://archive.ntp.org/ntp4/ntp-"
-                  (version-major+minor version)
-                  "/ntp-" version ".tar.gz"))
+	    (uri (list (string-append
+                         "http://archive.ntp.org/ntp4/ntp-"
+                         (version-major+minor version)
+                         "/ntp-" version ".tar.gz")
+                       (string-append
+                         "https://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-"
+                         (version-major+minor version)
+                         "/ntp-" version ".tar.gz")))
 	    (sha256
 	     (base32
               "1p100856h17nb0kpnppy70nja57hbcc95h7shhxvw6mhl030rll1"))