summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-20 14:48:43 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-08-20 18:33:51 +0200
commit06c91c7651405338c1de1d71be4f203988e3722b (patch)
tree69df2112383455b6485eee64849b0b5b0bb2b86c /gnu/packages/ocaml.scm
parent82f66e98b1f4e92cd1f98c701230a1e63f9c6d48 (diff)
downloadguix-06c91c7651405338c1de1d71be4f203988e3722b.tar.gz
gnu: camlzip: Fix reference to output.
* gnu/packages/ocaml.scm
  (camlzip)[arguments]<#:make-flags>: Use #$output.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 1e32ebee60..66d4460446 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1392,9 +1392,8 @@ other XUnit testing frameworks.")
                    (format port "directory=\"../zip\"\n")))))))
        #:install-target "install-findlib"
        #:make-flags
-       (list "all" "allopt"
-             (string-append "INSTALLDIR=" (assoc-ref %outputs "out")
-                            "/lib/ocaml"))))
+       ,#~(list "all" "allopt"
+                (string-append "INSTALLDIR=" #$output "/lib/ocaml"))))
     (home-page "https://github.com/xavierleroy/camlzip")
     (synopsis "Provides easy access to compressed files")
     (description "Provides easy access to compressed files in ZIP, GZIP and