summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 11:49:41 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:12:55 +0100
commit0806c87cb288b90b99bf2620e03beaad25a4b4dd (patch)
treeb9d136e32da94c413e5af363cb08e3326967ef51 /gnu/packages/ocaml.scm
parentaca25d415b0c59b4b692d06bb2194c9274399452 (diff)
downloadguix-0806c87cb288b90b99bf2620e03beaad25a4b4dd.tar.gz
gnu: Remove ocaml4.07-re.
* gnu/packages/ocaml.scm (ocaml4.07-re): Remove variable.
(ocaml-re)[properties]: Remove variant.

Change-Id: Ib3cf5188737579908e945bd49617b6d717da4250
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm13
1 files changed, 0 insertions, 13 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 0ab46bb8bf..82d6aec9a8 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4521,7 +4521,6 @@ standard iterator type starting from 4.07.")
      (list ocaml-seq))
     (native-inputs
      `(("ounit" ,ocaml-ounit)))
-    (properties `((ocaml4.07-variant . ,(delay ocaml4.07-re))))
     (home-page "https://github.com/ocaml/ocaml-re/")
     (synopsis "Regular expression library for OCaml")
     (description "Pure OCaml regular expressions with:
@@ -4534,18 +4533,6 @@ standard iterator type starting from 4.07.")
 @end enumerate")
     (license license:expat)))
 
-(define-public ocaml4.07-re
-  (package-with-ocaml4.07
-    (package
-      (inherit ocaml-re)
-      (arguments
-       `(#:phases
-         (modify-phases %standard-phases
-           (add-after 'unpack 'fix-dune-version
-             (lambda _
-               (delete-file "dune-project"))))))
-      (properties '()))))
-
 (define-public ocaml-ocplib-endian
   (package
     (name "ocaml-ocplib-endian")