summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2024-01-10 08:43:29 +0100
committerJulien Lepiller <julien@lepiller.eu>2024-02-08 23:22:48 +0100
commit1cbb3fd8f0dd4511d52b07dd1937e167b522fa76 (patch)
tree275f6e1c8b47210a9b647a3e05c6c76c738a663f /gnu/packages/ocaml.scm
parentb2a71b868ce3fed5779eebc172c239307bf9a4bc (diff)
downloadguix-1cbb3fd8f0dd4511d52b07dd1937e167b522fa76.tar.gz
gnu: Add dune-dyn.
* gnu/packages/ocaml.scm (dune-dyn): New variable.

Change-Id: I34907a758c146d9f18ab5807c069dfe104e6854f
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index aaa9e23982..55bf4bfbeb 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2047,6 +2047,19 @@ about.")
     (synopsis "Dune element ordering")
     (description "This library represents element ordering in OCaml.")))
 
+(define-public dune-dyn
+  (package
+    (inherit dune-ordering)
+    (name "dune-dyn")
+    (build-system dune-build-system)
+    (arguments
+     `(#:package "dyn"
+       ;; Tests have a cyclic dependency on stdune
+       #:tests? #f))
+    (propagated-inputs (list ocaml-pp dune-ordering))
+    (synopsis "Dune dynamic types")
+    (description "This library represents dynamic types in OCaml.")))
+
 (define-public ocaml-csexp
   (package
     (name "ocaml-csexp")