summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-08-22 12:27:06 -0500
committerEric Bavier <bavier@member.fsf.org>2016-08-22 23:59:54 -0500
commit2385cab1642ca974f4f892305c956277ee0d9341 (patch)
treea024e02c1f44094d887415a3cd75f750c04ff270 /gnu/packages/ocaml.scm
parent1d33b9eaa96067a8ff2d57da072cad3a83658e2b (diff)
downloadguix-2385cab1642ca974f4f892305c956277ee0d9341.tar.gz
gnu: opam: Use modify-phases.
* gnu/packages/ocaml.scm (opam)[arguments]: Use modify-phases.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm26
1 files changed, 12 insertions, 14 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c14d83c016..de2ac7cc97 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -176,20 +176,18 @@ functional, imperative and object-oriented styles of programming.")
        ;;   …/_obuild/opam/opam.asm install P1' failed.
        #:tests? #f
 
-       #:phases (alist-cons-before
-                 'build 'pre-build
-                 (lambda* (#:key inputs #:allow-other-keys)
-                   (let ((bash (assoc-ref inputs "bash")))
-                     (substitute* "src/core/opamSystem.ml"
-                       (("\"/bin/sh\"")
-                        (string-append "\"" bash "/bin/sh\"")))))
-                 (alist-cons-before
-                  'check 'pre-check
-                  (lambda _
-                    (setenv "HOME" (getcwd))
-                    (and (system "git config --global user.email guix@gnu.org")
-                         (system "git config --global user.name Guix")))
-                  %standard-phases))))
+       #:phases (modify-phases %standard-phases
+                 (add-before 'build 'pre-build
+                   (lambda* (#:key inputs make-flags #:allow-other-keys)
+                     (let ((bash (assoc-ref inputs "bash")))
+                       (substitute* "src/core/opamSystem.ml"
+                         (("\"/bin/sh\"")
+                          (string-append "\"" bash "/bin/sh\""))))))
+                 (add-before 'check 'pre-check
+                   (lambda _
+                     (setenv "HOME" (getcwd))
+                     (and (system "git config --global user.email guix@gnu.org")
+                          (system "git config --global user.name Guix")))))))
     (native-inputs
      `(("git" ,git)                               ;for the tests
        ("python" ,python)))                       ;for the tests