summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorSimon Tournier <zimon.toutoune@gmail.com>2023-09-15 13:12:11 +0200
committerSimon Tournier <zimon.toutoune@gmail.com>2023-09-22 15:04:00 +0200
commit3a7a81b4712a76dd40699bc0940ac366680f053a (patch)
treed2b90d158369bcfa643e891f405a89ebc7513b56 /gnu/packages/ocaml.scm
parent47ba771548b50914895448552b7f85973694d579 (diff)
downloadguix-3a7a81b4712a76dd40699bc0940ac366680f053a.tar.gz
gnu: bap: Update to 2.6.0-alpha-0.f995d28.
* gnu/packages/ocaml.scm (bap): Update to 2.6.0-alpha-0.f995d28.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 8f4dd1b357..8543505dbb 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5325,11 +5325,12 @@ necessary set of rewriters.")
 
 (define-public bap
   (let (;; Let pin one commit because -alpha is subject to change.
+        ;; The last stable release v2.5.0 is from July 2022.
         (revision "0")
-        (commit "a972f8a419294dfb21847db5172ba58c5d7767eb"))
+        (commit "f995d28a4a34abb4cef8e0b3bd3c41cd710ccf1a"))
     (package
       (name "bap")
-      (version (git-version "2.5.0-alpha" revision commit))
+      (version (git-version "2.6.0-alpha" revision commit))
       (home-page "https://github.com/BinaryAnalysisPlatform/bap")
       (source (origin
                 (method git-fetch)
@@ -5339,7 +5340,7 @@ necessary set of rewriters.")
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "1fw9pp0xnssc08qqfkcafffap4f46hw7zmk80gif5yc4nazga8w5"))))
+                  "1zfkc8nagf8kvxbypalbhf6gs0c7i48zx53hlpak2ipjwhvm5im5"))))
       (build-system ocaml-build-system)
       (arguments
        (list