summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2023-10-14 12:06:32 +0000
committerLudovic Courtès <ludo@gnu.org>2023-10-20 00:33:26 +0200
commit6156bf9078e52483cad01ca3fad2ad793773d0bc (patch)
tree58f713281fc85364849041e996af19a0d3f38218 /gnu/packages/ocaml.scm
parentdd19f3c39de08c1bd48adf571424a7169c968f52 (diff)
downloadguix-6156bf9078e52483cad01ca3fad2ad793773d0bc.tar.gz
gnu: unison: Update to 2.53.3.
* gnu/packages/ocaml.scm (unison): Update to 2.53.0.
  [source]: Remove patch.
  [build-system]: Use dune-build-system.
  [outputs]: Remove "doc" output.
  [native-inputs]: Update package style.
  [propagated-inputs]: Add lablgtk3 and zlib.
  [arguments]: Enable tests.
  <#:phases>: Remove prepare-install and install-fsmonitor phases.
* gnu/packages/patches/unison-fix-ocaml-4.08.patch: Remove file.
* gnu/local.mk: Unregister.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm50
1 files changed, 8 insertions, 42 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 8543505dbb..7993dbaa73 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1359,7 +1359,7 @@ libpanel, librsvg and quartz.")
 (define-public unison
   (package
     (name "unison")
-    (version "2.51.2")
+    (version "2.53.3")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1368,52 +1368,18 @@ libpanel, librsvg and quartz.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1bykiyc0dc5pkw8x370qkg2kygq9pq7yqzsgczd3y13b6ivm4sdq"))
-              (patches (search-patches "unison-fix-ocaml-4.08.patch"))))
-    (build-system gnu-build-system)
-    (outputs '("out"
-               "doc"))                  ; 1.9 MiB of documentation
-    (native-inputs
-     `(("ocaml" ,ocaml-4.09)
-       ;; For documentation
-       ("ghostscript" ,ghostscript)
-       ("texlive" ,(texlive-updmap.cfg))
-       ("hevea" ,hevea)
-       ("lynx" ,lynx)
-       ("which" ,which)))
-    (arguments
-     `(#:parallel-build? #f
-       #:parallel-tests? #f
-       #:test-target "selftest"
-       #:tests? #f ; Tests require writing to $HOME.
-                   ; If some $HOME is provided, they fail with the message
-                   ; "Fatal error: Skipping some tests -- remove me!"
-       #:phases
+                "05ihxk1yynw08586i06w19xab9r24h9hr6v9bknqm98qrlshm92w"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list lablgtk3 zlib))
+    (native-inputs (list ghostscript (texlive-updmap.cfg '()) hevea lynx which))
+    (arguments
+     `(#:phases
          (modify-phases %standard-phases
-           (delete 'configure)
-           (add-before 'install 'prepare-install
-             (lambda* (#:key outputs #:allow-other-keys)
-               (let* ((out (assoc-ref outputs "out"))
-                      (bin (string-append out "/bin")))
-                 (mkdir-p bin)
-                 (setenv "HOME" out) ; forces correct INSTALLDIR in Makefile
-                 #t)))
-           (add-after 'install 'install-fsmonitor
-             (lambda* (#:key outputs #:allow-other-keys)
-               (let* ((out (assoc-ref outputs "out"))
-                      (bin (string-append out "/bin")))
-                 ;; 'unison-fsmonitor' is used in "unison -repeat watch" mode.
-                 (install-file "src/unison-fsmonitor" bin)
-                 #t)))
            (add-after 'install 'install-doc
              (lambda* (#:key outputs #:allow-other-keys)
-               (let ((doc (string-append (assoc-ref outputs "doc")
+               (let ((doc (string-append (assoc-ref outputs "out")
                                          "/share/doc/unison")))
                  (mkdir-p doc)
-                 ;; Remove an '\n' that prevents the doc to be generated
-                 ;; correctly with newer hevea.
-                 (substitute* "doc/local.tex"
-                   (("----SNIP----.*") "----SNIP----"))
                  ;; This file needs write-permissions, because it's
                  ;; overwritten by 'docs' during documentation generation.
                  (chmod "src/strings.ml" #o600)