summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-28 10:49:02 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-28 11:25:14 +0200
commit8684575a88fc19d6b421af46d19fa64e1bf613fa (patch)
treef9a20e9e1d10e3ec0524ac42a262ac0f0d27f690 /gnu/packages/ocaml.scm
parent19568f9e79ed74b7100d25d3f2ea245f857ca742 (diff)
downloadguix-8684575a88fc19d6b421af46d19fa64e1bf613fa.tar.gz
gnu: ocaml-lwt: Don't use unstable tarball.
* gnu/packages/ocaml.scm (ocaml-lwt)[source]: Download using git-fetch.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index df998af1f5..a8fdd00d8e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1784,12 +1784,13 @@ for mapping files in memory.  This function is the same as the
     (version "5.1.1")
     (source
       (origin
-        (method url-fetch)
-        (uri (string-append "https://github.com/ocsigen/lwt/archive/" version
-                            ".tar.gz"))
-        (file-name (string-append name "-" version ".tar.gz"))
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/ocsigen/lwt")
+               (commit version)))
+        (file-name (git-file-name name version))
         (sha256 (base32
-                  "0gwdmhn0qx03agc45dplj73ia5y1gb42aan64ywfxmll3lsnr2h7"))))
+                 "1nl7rdnwfdhwcsm5zpay1nr9y5cbapd9x1qzily7zk9ab4v52m8g"))))
     (build-system dune-build-system)
     (arguments
      `(#:package "lwt"))