summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorArnaud DABY-SEESARAM <ds-ac@nanein.fr>2024-01-10 08:43:25 +0100
committerJulien Lepiller <julien@lepiller.eu>2024-02-08 23:21:07 +0100
commit93f4f69a6931f56cdc36619925ff5a21c5c2d846 (patch)
tree13ae115fce77757b622956e6229d6d7e56b222fa /gnu/packages/ocaml.scm
parentc1a12ad8ad42b391e81557d14864552cf6d47aba (diff)
downloadguix-93f4f69a6931f56cdc36619925ff5a21c5c2d846.tar.gz
gnu: Add ocaml-ppx-deriving-yaml.
* gnu/packages/ocaml.scm (ocaml-ppx-deriving-yaml): New variable.

Change-Id: I2677ce5b630b77abdec7743cd25c4193ca7b351e
Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm29
1 files changed, 27 insertions, 2 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 30ebe96a5b..8b443f38a3 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2622,10 +2622,10 @@ syntactic tools.")
        (method git-fetch)
        (uri (git-reference
               (url home-page)
-              (commit version)))
+              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "054ca6071bfkdbm5vlmnk6ic43561xl9igv87zgkbq4qry16a7s7"))))
+        (base32 "1m0i9qdazmziswfw1bz4m1x9mlzqyv336vbrss0c21am4im9n6k6"))))
     (build-system dune-build-system)
     (propagated-inputs (list ocaml-ppx-sexp-conv ocaml-ctypes ocaml-bos))
     (native-inputs (list ocaml-fmt
@@ -2645,6 +2645,31 @@ other advanced Yaml features are not implemented in the JSON compatibility
 layer.")
     (license license:isc)))
 
+(define-public ocaml-ppx-deriving-yaml
+  (package
+    (name "ocaml-ppx-deriving-yaml")
+    (version "0.2.1")
+    (home-page "https://github.com/patricoferris/ppx_deriving_yaml")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+              (url home-page)
+              (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1cxcqgvyl4ykyl86mf2d4ka6frnq51m1yqy0z5v6vdxkixllf9jd"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list ocaml-ppxlib ocaml-ppx-deriving ocaml-yaml
+                             ocaml-odoc))
+    (native-inputs (list ocaml-alcotest ocaml-bos ocaml-mdx ocaml-ezjsonm))
+    (properties `((upstream-name . "ppx_deriving_yaml")))
+    (synopsis "Yaml PPX Deriver")
+    (description
+     "This package contains @code{deriving} conversion functions to and from
+yaml for OCaml types.")
+    (license license:isc)))
+
 (define-public ocaml-parmap
   (package
     (name "ocaml-parmap")