summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2023-02-15 22:59:52 +0100
committerChristopher Baines <mail@cbaines.net>2023-02-17 15:44:53 +0000
commita0606cc03e942750ec578ae9600537b54514a582 (patch)
tree5c04d12cb643cf5ee02ba4dc2da04413b8f17997 /gnu/packages/ocaml.scm
parent4d4486a5c2edc0b1c85eb6e9704e8211a05eb440 (diff)
downloadguix-a0606cc03e942750ec578ae9600537b54514a582.tar.gz
gnu: Add ocaml-ipaddr.
* gnu/packages/ocaml.scm (ocaml-ipaddr): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 7fb32ade5a..e3e63c26b4 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3581,6 +3581,19 @@ length of domain names are preserved throughout the module.")
 @end itemize")
     (license license:isc)))
 
+(define-public ocaml-ipaddr
+  ;; same repo and versions as ocaml-macaddr
+  (package
+    (inherit ocaml-macaddr)
+    (name "ocaml-ipaddr")
+    (arguments '(#:package "ipaddr"))
+    (propagated-inputs (list ocaml-macaddr ocaml-domain-name))
+    (synopsis
+     "Library for manipulation of IP (and MAC) address representations")
+    (description
+     "IP address types with serialization, supporting a wide range of RFCs.")
+    (license license:isc)))
+
 (define-public ocaml-ocurl
   (package
     (name "ocaml-ocurl")