summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 11:13:39 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:11:40 +0100
commitbffb7e524bbf9f88643af745a3d8b9a6cd6ce60f (patch)
treea3e1d49199bb101b7c502a44fc2745b7f4c2abf8 /gnu/packages/ocaml.scm
parent7c8ee30ca691c4fdf57f0868fe56e2eaefe878f8 (diff)
downloadguix-bffb7e524bbf9f88643af745a3d8b9a6cd6ce60f.tar.gz
gnu: Remove ocaml4.07-typerep.
* gnu/packages/ocaml.scm (ocaml4.07-typerep): Remove variable.
(ocaml-typerep)[properties]: Remove variant.

Change-Id: I6e856bd96ca7dedeb0078e662b19a1f12143c0d2
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm17
1 files changed, 0 insertions, 17 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 5010377fc8..584e3cf35e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6922,28 +6922,11 @@ many values).")
     (build-system dune-build-system)
     (arguments `(#:tests? #f)); no tests
     (propagated-inputs (list ocaml-base))
-    (properties `((ocaml4.07-variant . ,(delay ocaml4.07-typerep))))
     (home-page "https://github.com/janestreet/typerep")
     (synopsis "Typerep is a library for runtime types")
     (description "Typerep is a library for runtime types.")
     (license license:expat)))
 
-(define-public ocaml4.07-typerep
-  (package-with-ocaml4.07
-    (package
-      (inherit ocaml-typerep)
-      (version "0.11.0")
-      (source (origin
-                (method url-fetch)
-                (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
-                                    (version-major+minor version)
-                                    "/files/typerep-v" version ".tar.gz"))
-                (sha256
-                 (base32
-                  "1zi7hy0prpgzqhr4lkacr04wvlvbp21jfbdfvffhrm6cd400rb5v"))))
-      (properties '())
-      (license license:asl2.0))))
-
 (define-public ocaml-ppx-sexp-value
   (package
     (name "ocaml-ppx-sexp-value")