summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 11:41:29 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:12:03 +0100
commitc02058bef6152f48b601aeb2c8334e08358ee625 (patch)
tree0b631e2874c788da91bdcb8857b1fcf1ea9d7418 /gnu/packages/ocaml.scm
parent697328419e365f3f93a205fc54be860b5bfd4263 (diff)
downloadguix-c02058bef6152f48b601aeb2c8334e08358ee625.tar.gz
gnu: Remove ocaml4.07-fieldslib.
* gnu/packages/ocaml.scm (ocaml4.07-fieldslib): Remove variable.
(ocaml-fieldslib)[properties]: Remove variant.

Change-Id: Ic915d16ee2f45a198f63896ad0ad22ac57815958
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm13
1 files changed, 1 insertions, 12 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index b5c576ac89..9c72b93f4d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6455,8 +6455,7 @@ by making sure that you only compare comparable values.")
     (arguments `(#:tests? #f)) ; No tests
     (propagated-inputs
      (list ocaml-base ocaml-migrate-parsetree ocaml-ppxlib))
-    (properties `((upstream-name . "fieldslib")
-                  (ocaml4.07-variant . ,(delay ocaml4.07-fieldslib))))
+    (properties `((upstream-name . "fieldslib")))
     (home-page "https://github.com/janestreet/fieldslib")
     (synopsis "Syntax extension to record fields")
     (description "Syntax extension to define first class values representing
@@ -6464,16 +6463,6 @@ record fields, to get and set record fields, iterate and fold over all fields
 of a record and create new record values.")
     (license license:asl2.0)))
 
-(define-public ocaml4.07-fieldslib
-  (package-with-ocaml4.07
-   (package
-     (inherit ocaml-fieldslib)
-     (version "0.11.0")
-     (source (janestreet-origin
-              "fieldslib" version
-              "12948pzxrl360lybm9fzyvplgcl87zjbn4m3sk1aw75zk85p1388"))
-     (properties `((upstream-name . "fieldslib"))))))
-
 (define-public ocaml-variantslib
   (package
     (name "ocaml-variantslib")