summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-06-19 17:50:41 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-06-20 02:15:10 +0200
commitdcd94ee855fa03596a8e84b7cffe1344bb6206ef (patch)
tree31492fbdc66145148cf6bd7688cede790265cc93 /gnu/packages/ocaml.scm
parent620b4e8ad3b8a6c3a770a5a3ab69b546d7570df7 (diff)
downloadguix-dcd94ee855fa03596a8e84b7cffe1344bb6206ef.tar.gz
gnu: Add ocaml-mparser-pcre.
* gnu/packages/ocaml.scm (ocaml-mparser-pcre): New variable.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f795f8d918..4e0c6458b6 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6842,6 +6842,21 @@ the FParsec library for FSharp by Stephan Tolksdorf.")
     (description "This package provides RE-based regular expressions
 support for Mparser.")))
 
+(define-public ocaml-mparser-pcre
+  (package
+    (inherit ocaml-mparser)
+    (name "ocaml-mparser-pcre")
+    (arguments
+     ;; No tests.
+     '(#:package "mparser-pcre"
+       #:tests? #f))
+    (propagated-inputs
+     `(("ocaml-mparser" ,ocaml-mparser)
+       ("ocaml-pcre" ,ocaml-pcre)))
+    (synopsis "MParser plugin for PCRE-based regular expressions")
+    (description "This package provides PCRE-based regular expressions
+support for Mparser.")))
+
 (define-public lablgtk3
   (package
     (name "lablgtk")