summary refs log tree commit diff
path: root/gnu/packages/pantheon.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-05-19 13:06:27 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-05-19 13:06:27 +0200
commitef3cd15ed4336f661df0f72d4ca9d7a8c7e87d13 (patch)
tree89502554fa6e8be4b7e03e59e08412997d1e991e /gnu/packages/pantheon.scm
parent969811ad0e51adcbf503e38d9c9265814e3c2e27 (diff)
downloadguix-ef3cd15ed4336f661df0f72d4ca9d7a8c7e87d13.tar.gz
gnu: granite: Fix cross-compilation.
* gnu/packages/pantheon.scm (granite)[native-inputs]: Remove glib, libgee.
[inputs]: Add glib, libgee.
Diffstat (limited to 'gnu/packages/pantheon.scm')
-rw-r--r--gnu/packages/pantheon.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 306a1d892d..72910e5470 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -52,12 +52,12 @@
              (setenv "DESTDIR" "/")
              #t)))))
     (inputs
-     `(("gtk" ,gtk+)))
+     `(("glib" ,glib)
+       ("gtk" ,gtk+)
+       ("libgee" ,libgee)))
     (native-inputs
      `(("gettext" ,gettext-minimal)
-       ("glib" ,glib)
        ("gobject-introspection" ,gobject-introspection)
-       ("libgee" ,libgee)
        ("pkg-config" ,pkg-config)
        ("vala" ,vala)))
     (home-page "https://github.com/elementary/granite")