summary refs log tree commit diff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2023-09-23 15:14:36 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-09-28 18:48:47 +0300
commit509239b3687569f34a378fc4ea1e2ba30f4c8cc3 (patch)
tree8af584eca7dc752e91f09c85154d59f81f28ff78 /gnu/packages/password-utils.scm
parent3963fa1a465708690cd1554d911613f1c92f5eef (diff)
downloadguix-509239b3687569f34a378fc4ea1e2ba30f4c8cc3.tar.gz
gnu: keepassxc: Switch to qt-build-system.
* gnu/packages/password-utils.scm (keepassxc): Use qt-build-system.
[build-system]: Switch to qt-build-system.
[arguments]: Drop superfluous phase and modules.
[inputs]: Drop qtbase-5.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm20
1 files changed, 6 insertions, 14 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index be85898c41..9558da1dee 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -63,6 +63,7 @@
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system go)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system qt)
   #:use-module (guix build-system trivial)
   #:use-module (guix download)
   #:use-module (guix gexp)
@@ -154,14 +155,9 @@ human.")
                            version "-src.tar.xz"))
        (sha256
         (base32 "0w6nh2lnzfqcxasfsppmh4q309p1flzgfiv25hahzsd8kx879055"))))
-    (build-system cmake-build-system)
+    (build-system qt-build-system)
     (arguments
      (list
-      #:modules '((guix build cmake-build-system)
-                  (guix build qt-utils)
-                  (guix build utils))
-      #:imported-modules `(,@%cmake-build-system-modules
-                           (guix build qt-utils))
       #:configure-flags
       #~(append
           (list "-DWITH_XC_ALL=YES"
@@ -175,13 +171,10 @@ human.")
           (replace 'check
             (lambda* (#:key tests? #:allow-other-keys)
               (when tests?
-                ;; Fails with "TestCli::testClip() Compared values are not the
-                ;; same".  That test also requires a phase with (setenv
-                ;; "QT_QPA_PLATFORM" "offscreen") in order to work.
-                (invoke "ctest" "--exclude-regex" "testcli"))))
-          (add-after 'install 'wrap-qt
-            (lambda* (#:key inputs #:allow-other-keys)
-              (wrap-qt-program "keepassxc" #:output #$output #:inputs inputs))))))
+                ;; "TestCli::testClip() Compared values are not the same".
+                ;;   Actual   (((clipboard->text()))): ""
+                ;;   Expected (QString("Password"))  : "Password"
+                (invoke "ctest" "--exclude-regex" "testcli")))))))
     (native-inputs
      (append
        (list qttools-5)
@@ -201,7 +194,6 @@ human.")
            minizip
            pcsc-lite
            qrencode
-           qtbase-5
            qtsvg-5
            qtwayland-5
            qtx11extras