summary refs log tree commit diff
path: root/gnu/packages/patches/ark-skip-xar-test.patch
diff options
context:
space:
mode:
authorZ572 <873216071@qq.com>2021-07-16 00:03:40 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-07-16 00:06:05 -0400
commit4094d12df13859b07c10a9664c4d6797ddbcbc2e (patch)
tree9f0ba7eca09953304497066b7dcf5adc83b87a60 /gnu/packages/patches/ark-skip-xar-test.patch
parentdd98685356377e61e0997c00a233d8467977833f (diff)
downloadguix-4094d12df13859b07c10a9664c4d6797ddbcbc2e.tar.gz
gnu: Add ark.
* gnu/packages/kde-utils.scm (ark): New variable.
* gnu/packages/patches/ark-skip-xar-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.

Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/patches/ark-skip-xar-test.patch')
-rw-r--r--gnu/packages/patches/ark-skip-xar-test.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/patches/ark-skip-xar-test.patch b/gnu/packages/patches/ark-skip-xar-test.patch
new file mode 100644
index 0000000000..525201997b
--- /dev/null
+++ b/gnu/packages/patches/ark-skip-xar-test.patch
@@ -0,0 +1,44 @@
+Guix libarchive no support xar.
+
+--- ark-20.04.1.orig/autotests/kerfuffle/loadtest.cpp	2020-12-23 08:46:15.780782601 +0800
++++ ark-20.04.1/autotests/kerfuffle/loadtest.cpp	2020-12-23 11:13:17.101724042 +0800
+@@ -181,13 +181,6 @@
+         qDebug() << "lz4 executable not found in path. Skipping lz4 test.";
+     }
+ 
+-    QTest::newRow("xar archive")
+-            << QFINDTESTDATA("data/simplearchive.xar")
+-            << QStringLiteral("simplearchive")
+-            << true << false << false << false << false << 0 << Archive::Unencrypted
+-            << QStringLiteral("simplearchive")
+-            << QString();
+-
+     QTest::newRow("mimetype child of application/zip")
+             << QFINDTESTDATA("data/test.odt")
+             << QStringLiteral("test")
+--- ark-20.04.1.orig/autotests/kerfuffle/extracttest.cpp	2020-12-23 08:46:15.780782601 +0800
++++ ark-20.04.1/autotests/kerfuffle/extracttest.cpp	2020-12-23 11:14:02.801809620 +0800
+@@ -350,23 +350,6 @@
+         qDebug() << "lz4 executable not found in path. Skipping lz4 test.";
+     }
+ 
+-    archivePath = QFINDTESTDATA("data/simplearchive.xar");
+-    QTest::newRow("extract selected entries from a xar archive without path")
+-            << archivePath
+-            << QVector<Archive::Entry*> {
+-                   new Archive::Entry(this, QStringLiteral("dir1/file11.txt"), QString()),
+-                   new Archive::Entry(this, QStringLiteral("file4.txt"), QString())
+-               }
+-            << optionsNoPaths
+-            << 2;
+-
+-    archivePath = QFINDTESTDATA("data/simplearchive.xar");
+-    QTest::newRow("extract all entries from a xar archive with path")
+-            << archivePath
+-            << QVector<Archive::Entry*>()
+-            << optionsPreservePaths
+-            << 6;
+-
+     archivePath = QFINDTESTDATA("data/hello-1.0-x86_64.AppImage");
+     QTest::newRow("extract all entries from an AppImage with path")
+             << archivePath