summary refs log tree commit diff
path: root/gnu/packages/patches/evolution-data-server-printableoptions.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-12 22:12:33 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-12 22:29:53 -0500
commitce7d93ceda06f0332617a29fe0181f13d2c0b369 (patch)
treed2cd9b5bed72c1fc697461971ed494008bf88ea9 /gnu/packages/patches/evolution-data-server-printableoptions.patch
parent1de8c00a7b743440943356bb086caaad58d489e9 (diff)
downloadguix-ce7d93ceda06f0332617a29fe0181f13d2c0b369.tar.gz
gnu: evolution-data-server: Update to 3.42.1.
* gnu/packages/gnome.scm (evolution-data-server): Update to 3.42.1.
Delete trailing #t.
[origin]: Remove patches.
[phases]{adjust-webkitgtk-version}: New phase.
* gnu/packages/patches/evolution-data-server-CVE-2020-14928.patch: Likewise.
* gnu/packages/patches/evolution-data-server-CVE-2020-16117.patch: Likewise.
* gnu/packages/patches/evolution-data-server-libical-compat.patch: Likewise.
* gnu/packages/patches/evolution-data-server-locales.patch: Likewise.
* gnu/packages/patches/evolution-data-server-printableoptions.patch: Likewise.
* gnu/local.mk (dist_patch_DATA): De-register them.
Diffstat (limited to 'gnu/packages/patches/evolution-data-server-printableoptions.patch')
-rw-r--r--gnu/packages/patches/evolution-data-server-printableoptions.patch57
1 files changed, 0 insertions, 57 deletions
diff --git a/gnu/packages/patches/evolution-data-server-printableoptions.patch b/gnu/packages/patches/evolution-data-server-printableoptions.patch
deleted file mode 100644
index e40c5f3875..0000000000
--- a/gnu/packages/patches/evolution-data-server-printableoptions.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-Patch adapted from upstream c3915bb99638c1ccf57217097b14b5db69bcac96
-by Milan Crha:
-
-    PrintableOptions.cmake: Correct variable name comparison
-    
-    CMake 3.20.1 errors out with:
-    
-    CMake Error at cmake/modules/PrintableOptions.cmake:38 (message):
-       variable name cannot be empty
-     Call Stack (most recent call first):
-       CMakeLists.txt:152 (add_printable_variable)
-    
-    Change how the parameter value is compared, to fix it.
-
---- a/cmake/modules/PrintableOptions.cmake
-+++ b/cmake/modules/PrintableOptions.cmake
-@@ -19,32 +19,32 @@
- #    prints all the build options previously added with the above functions
- 
- macro(add_printable_variable_bare _name)
--	if(_name STREQUAL "")
-+	if("${_name}" STREQUAL "")
- 		message(FATAL_ERROR "variable name cannot be empty")
--	endif(_name STREQUAL "")
-+	endif("${_name}" STREQUAL "")
- 	list(APPEND _printable_options ${_name})
- endmacro()
- 
- macro(add_printable_option _name _description _default_value)
--	if(_name STREQUAL "")
-+	if("${_name}" STREQUAL "")
- 		message(FATAL_ERROR "option name cannot be empty")
--	endif(_name STREQUAL "")
-+	endif("${_name}" STREQUAL "")
- 	option(${_name} ${_description} ${_default_value})
- 	add_printable_variable_bare(${_name})
- endmacro()
- 
- macro(add_printable_variable _name _description _default_value)
--	if(_name STREQUAL "")
-+	if("${_name}" STREQUAL "")
- 		message(FATAL_ERROR "variable name cannot be empty")
--	endif(_name STREQUAL "")
-+	endif("${_name}" STREQUAL "")
- 	set(${_name} ${_default_value} CACHE STRING ${_description})
- 	add_printable_variable_bare(${_name})
- endmacro()
- 
- macro(add_printable_variable_path _name _description _default_value)
--	if(_name STREQUAL "")
-+	if("${_name}" STREQUAL "")
- 		message(FATAL_ERROR "path variable name cannot be empty")
--	endif(_name STREQUAL "")
-+	endif("${_name}" STREQUAL "")
- 	set(${_name} ${_default_value} CACHE PATH ${_description})
- 	add_printable_variable_bare(${_name})
- endmacro()