summary refs log tree commit diff
path: root/gnu/packages/patches/libvpx-CVE-2016-2818.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-06-08 09:53:56 -0400
committerMark H Weaver <mhw@netris.org>2016-06-08 14:26:54 -0400
commitc7c49446ebcc48c2b2136f4475ab66aecb63d18e (patch)
tree8e91fef284168515572e3c4027cc41da5a0cfb04 /gnu/packages/patches/libvpx-CVE-2016-2818.patch
parent93961f02987cf738d116cc85cc32d97c2a488222 (diff)
downloadguix-c7c49446ebcc48c2b2136f4475ab66aecb63d18e.tar.gz
gnu: libvpx: Add fix for CVE-2016-2818.
* gnu/packages/patches/libvpx-CVE-2016-2818.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/video.scm (libvpx)[source]: Add patch.
Diffstat (limited to 'gnu/packages/patches/libvpx-CVE-2016-2818.patch')
-rw-r--r--gnu/packages/patches/libvpx-CVE-2016-2818.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/patches/libvpx-CVE-2016-2818.patch b/gnu/packages/patches/libvpx-CVE-2016-2818.patch
new file mode 100644
index 0000000000..1fdf01cbca
--- /dev/null
+++ b/gnu/packages/patches/libvpx-CVE-2016-2818.patch
@@ -0,0 +1,36 @@
+Patch contents copied from Mozilla esr45 changeset 312077:7ebfe49f001c
+
+  changeset:   312077:7ebfe49f001c
+  user:        Randell Jesup <rjesup@jesup.org>
+  Date:        Fri Apr 15 23:11:01 2016 -0400
+  summary:     Bug 1263384: validate input frames against configured resolution in vp8 r=rillian, a=ritu,lizzard
+
+  MozReview-Commit-ID: BxDCnJe0mzs
+
+--- libvpx-1.5.0/vp8/vp8_cx_iface.c.orig	2015-11-09 17:12:38.000000000 -0500
++++ libvpx-1.5.0/vp8/vp8_cx_iface.c	2016-06-08 08:48:46.037213092 -0400
+@@ -925,11 +925,19 @@
+         {
+             res = image2yuvconfig(img, &sd);
+ 
+-            if (vp8_receive_raw_frame(ctx->cpi, ctx->next_frame_flag | lib_flags,
+-                                      &sd, dst_time_stamp, dst_end_time_stamp))
+-            {
+-                VP8_COMP *cpi = (VP8_COMP *)ctx->cpi;
+-                res = update_error_state(ctx, &cpi->common.error);
++            if (sd.y_width != ctx->cfg.g_w || sd.y_height != ctx->cfg.g_h) {
++                /* from vp8_encoder.h for g_w/g_h:
++                   "Note that the frames passed as input to the encoder must have this resolution"
++                */
++                ctx->base.err_detail = "Invalid input frame resolution";
++                res = VPX_CODEC_INVALID_PARAM;
++            } else {
++                if (vp8_receive_raw_frame(ctx->cpi, ctx->next_frame_flag | lib_flags,
++                                          &sd, dst_time_stamp, dst_end_time_stamp))
++                {
++                    VP8_COMP *cpi = (VP8_COMP *)ctx->cpi;
++                    res = update_error_state(ctx, &cpi->common.error);
++                }
+             }
+ 
+             /* reset for next frame */