summary refs log tree commit diff
path: root/gnu/packages/patches/python-uqbar-python3.10.patch
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2024-01-07 21:27:27 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2024-01-07 21:27:27 -0500
commitd9dee5ea2f564fa6979ae552fd9bd5ac22f86ecc (patch)
tree8d1b2f89808f9e7ddbeddeab7563f3ab82e533cd /gnu/packages/patches/python-uqbar-python3.10.patch
parentef4e4c9a2ccc1678182fa6e4409fff13c669fd14 (diff)
parent3de361d9c9d320aefbd43710124d7b07af891de1 (diff)
downloadguix-d9dee5ea2f564fa6979ae552fd9bd5ac22f86ecc.tar.gz
Merge branch 'master' into mesa-updates
Change-Id: I0b92a95109688a1a4c50572bc25a4e5676e0921e
Diffstat (limited to 'gnu/packages/patches/python-uqbar-python3.10.patch')
-rw-r--r--gnu/packages/patches/python-uqbar-python3.10.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-uqbar-python3.10.patch b/gnu/packages/patches/python-uqbar-python3.10.patch
new file mode 100644
index 0000000000..164f0c0c64
--- /dev/null
+++ b/gnu/packages/patches/python-uqbar-python3.10.patch
@@ -0,0 +1,23 @@
+Since Python 3.10 the output of a CLI program created with argparse
+uses "options" instead of "optional arguments". This behaviour breaks
+the tests in python-uqbar.
+
+--- a/tests/test_cli.py
++++ b/tests/test_cli.py
+@@ -84,7 +84,7 @@ def test_call_help():
+ 
+         speak like a cat
+ 
+-        optional arguments:
++        options:
+           -h, --help  show this help message and exit
+           --version   show program's version number and exit
+           --loud      be adamant
+@@ -101,6 +101,6 @@ def test_help():
+         """
+         usage: vox-aggregator [-h] [--version] {help,list,birds,mammals} ...
+ 
+-        optional arguments:
++        options:
+           -h, --help            show this help message and exit
+           --version             show program's version number and exit