summary refs log tree commit diff
path: root/gnu/packages/patches/qtdeclarative-disable-qmlcache.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-11 15:26:14 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-22 12:32:20 -0400
commit1717c8a233b7fda3a10aabc061168c71317f883e (patch)
tree421fa5e5e0458f0d67beaa89d83280eb814523b2 /gnu/packages/patches/qtdeclarative-disable-qmlcache.patch
parent41e62900d73c828200e01ca0df7190b0a5f8d122 (diff)
downloadguix-1717c8a233b7fda3a10aabc061168c71317f883e.tar.gz
gnu: qtdeclarative: Disable QML cache to avoid stale cache issues.
Fixes <https://issues.guix.gnu.org/64605> and similar reports.

* gnu/packages/patches/qtdeclarative-5-disable-qmlcache.patch: New patch.
* gnu/packages/patches/qtdeclarative-disable-qmlcache.patch: Likewise.
* gnu/local.mk (dist_patch_DATA): Register them.
* gnu/packages/qt.scm (qtdeclarative-5, qtdeclarative): Apply them.

Reported-by: Distopico Vegan <distopico@riseup.net>
Diffstat (limited to 'gnu/packages/patches/qtdeclarative-disable-qmlcache.patch')
-rw-r--r--gnu/packages/patches/qtdeclarative-disable-qmlcache.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/qtdeclarative-disable-qmlcache.patch b/gnu/packages/patches/qtdeclarative-disable-qmlcache.patch
new file mode 100644
index 0000000000..5f06ec53b4
--- /dev/null
+++ b/gnu/packages/patches/qtdeclarative-disable-qmlcache.patch
@@ -0,0 +1,16 @@
+Retrieved from
+https://raw.githubusercontent.com/NixOS/nixpkgs/master/pkgs/development/libraries/qt-6/patches/qtdeclarative-default-disable-qmlcache.patch
+
+diff --git a/src/qml/jsruntime/qv4engine.cpp b/src/qml/jsruntime/qv4engine.cpp
+index 852cde9e..165f1b57 100644
+--- a/src/qml/jsruntime/qv4engine.cpp
++++ b/src/qml/jsruntime/qv4engine.cpp
+@@ -2093,7 +2093,7 @@ void ExecutionEngine::registerModule(const QString &_name, const QJSValue &modul
+ 
+ bool ExecutionEngine::diskCacheEnabled() const
+ {
+-    return (!disableDiskCache() && !debugger()) || forceDiskCache();
++    return forceDiskCache();
+ }
+ 
+ void ExecutionEngine::callInContext(QV4::Function *function, QObject *self,