summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2022-06-23 23:06:55 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-23 23:54:19 -0400
commit185ae9b410a43f0415e83f9fb88549c21ca4a673 (patch)
tree45f6257c65860a0b9674f4c072f5364872e338b6 /gnu/packages/patches
parent6c1dac4f06a2dddf1f30bea6bf8edfeb74a1ebb7 (diff)
downloadguix-185ae9b410a43f0415e83f9fb88549c21ca4a673.tar.gz
gnu: docker: Update to 20.10.17.
* gnu/packages/docker.scm (%docker-version): Update to 20.10.17.
(docker-libnetwork)[source]: Update commit according to vendor.conf.  Reset
revision to 1.  Simplify snippet.
(docker)[origin]: Remove docker-fix-tests.patch.
[arguments]: Adapt 'patch-paths phase, substitute "ip6tables" and
buildkit-qemu.  Remove trailing #t.
[native-inputs]: Replace go-1.14 by go.
(docker-cli)[source]: Update hash.
[arguments]: Set GO_LINKMODE to "dynamic".  Remove trailing #t.
[phases]{check}: Replace 'if' with 'when'.
* gnu/packages/networking.scm (go-sctp): Update commit according to
docker-libnetwork's vendor.conf.
* gnu/packages/patches/docker-fix-tests.patch: Delete.
* gnu/local.mk (dist_patch_DATA): Remove patch.

Co-authored-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/docker-fix-tests.patch28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/patches/docker-fix-tests.patch b/gnu/packages/patches/docker-fix-tests.patch
deleted file mode 100644
index 3e3e318e25..0000000000
--- a/gnu/packages/patches/docker-fix-tests.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Author: Danny Milosavljevic <dannym@scratchpost.org>
-The socket name ended up too long inside the container.
-Use a shorter one.
---- a/pkg/authorization/authz_unix_test.go	2019-01-10 01:55:02.997985947 +0100
-+++ b/pkg/authorization/authz_unix_test.go	2019-01-10 02:03:21.177439757 +0100
-@@ -24,7 +24,7 @@
- )
- 
- const (
--	pluginAddress = "authz-test-plugin.sock"
-+	pluginAddress = "/tmp/authz-test-plugin.sock"
- )
- 
- func TestAuthZRequestPluginError(t *testing.T) {
-@@ -263,12 +263,7 @@
- 
- // createTestPlugin creates a new sample authorization plugin
- func createTestPlugin(t *testing.T) *authorizationPlugin {
--	pwd, err := os.Getwd()
--	if err != nil {
--		t.Fatal(err)
--	}
--
--	client, err := plugins.NewClient("unix:///"+path.Join(pwd, pluginAddress), &tlsconfig.Options{InsecureSkipVerify: true})
-+	client, err := plugins.NewClient("unix:///"+path.Join("/", pluginAddress), &tlsconfig.Options{InsecureSkipVerify: true})
- 	if err != nil {
- 		t.Fatalf("Failed to create client %v", err)
- 	}