summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2023-12-01 10:35:38 -0500
committerLudovic Courtès <ludo@gnu.org>2023-12-13 12:58:43 +0100
commit1b2505217cf222d98cc960b8510660976a01cfa1 (patch)
tree5af8dcaaf23cac65bf7c7b13b7a89433bffe9992 /gnu/packages/patches
parenteb1f019f770999585f3f92b35e0ee195b595d859 (diff)
downloadguix-1b2505217cf222d98cc960b8510660976a01cfa1.tar.gz
gnu: racket: Update to 8.11.1.
* gnu/packages/patches/racket-backport-8.10-rktboot.patch: Delete file.
* gnu/packages/patches/racket-backport-8.11-layered-docs.patch: New file.
* gnu/local.mk (dist_patch_DATA): Update accordingly.
* gnu/packages/racket/scm (%racket-origin)[patches]: Likewise.
(%racket-version): Update to 8.11.1.
(%zuo-version): Update to 1.7.
(racket)[inputs]<deinprogramm, draw, drracket, games, gui, htdp>
<parser-tools, plot, rackunit, redex, scribble, slideshow, typed-racket>
<srfi, string-constants, syntax-color, web-server, xrepl>: Update hashes.
<quickscript>: Likewise, and add snippet.
* gnu/packages/chez.scm (chez-scheme-for-racket): Update to
9.9.9-pre-release.18.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/racket-backport-8.10-rktboot.patch130
-rw-r--r--gnu/packages/patches/racket-backport-8.11-layered-docs.patch36
2 files changed, 36 insertions, 130 deletions
diff --git a/gnu/packages/patches/racket-backport-8.10-rktboot.patch b/gnu/packages/patches/racket-backport-8.10-rktboot.patch
deleted file mode 100644
index 834001bd83..0000000000
--- a/gnu/packages/patches/racket-backport-8.10-rktboot.patch
+++ /dev/null
@@ -1,130 +0,0 @@
-From 5446e36e0685ec5c7b4f812dec5bf7959db4f906 Mon Sep 17 00:00:00 2001
-From: Efraim Flashner <efraim@flashner.co.il>
-Date: Thu, 20 Jul 2023 15:56:21 +0300
-Subject: [PATCH 1/2] rktboot: Add support for riscv64.
-
-(cherry picked from commit f80c5d001d5235556ae9cde617b1e3a1322d0505)
----
- racket/src/rktboot/machine-def.rkt | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/racket/src/rktboot/machine-def.rkt b/racket/src/rktboot/machine-def.rkt
-index 8ff0688652..59ebfc88d8 100644
---- a/racket/src/rktboot/machine-def.rkt
-+++ b/racket/src/rktboot/machine-def.rkt
-@@ -25,6 +25,7 @@
-                                      [(regexp-match? #rx"^t?arm32" target-machine) "arm32"]
-                                      [(regexp-match? #rx"^t?arm64" target-machine) "arm64"]
-                                      [(regexp-match? #rx"^t?ppc32" target-machine) "ppc32"]
-+                                     [(regexp-match? #rx"^t?rv64" target-machine) "rv64"]
-                                      [(regexp-match? #rx"^t?pb" target-machine) "pb"]
-                                      [else (error "machine.def: cannot infer architecture")]))]
-                [s (regexp-replace* #rx"[$][(]Mend[)]" s
-
-base-commit: b10ecfb8311fca2d42636eea2ca12aff0b76b208
--- 
-2.41.0
-
-
-From 6261c3582c386e770d654ca6a36f112834f35aef Mon Sep 17 00:00:00 2001
-From: Philip McGrath <philip@philipmcgrath.com>
-Date: Sun, 16 Jul 2023 15:47:14 -0400
-Subject: [PATCH 2/2] rktboot: improve machene type inference
-
-Related to https://issues.guix.gnu.org/62231
-Related to https://github.com/racket/racket/issues/3948
-
-(cherry picked from commit 005488491cee89e7db38109de4c9dcf2d8d5aef0)
----
- racket/src/rktboot/config.rkt | 73 +++++++++++++++++++++++++++++------
- 1 file changed, 61 insertions(+), 12 deletions(-)
-
-diff --git a/racket/src/rktboot/config.rkt b/racket/src/rktboot/config.rkt
-index 7a969017ed..2b411e002c 100644
---- a/racket/src/rktboot/config.rkt
-+++ b/racket/src/rktboot/config.rkt
-@@ -15,20 +15,69 @@
-                                (path->complete-path scheme-dir))))))
- (hash-set! ht 'make-boot-scheme-dir scheme-dir)
- 
-+(define (infer-target-machine)
-+  ;; Compute a native or pbarch machine string for the current platform.
-+  ;; Some caveats:
-+  ;;  1. A pbarch Racket will always infer a pbarch machine,
-+  ;;     even if a native machine exists. Hopefully this is an
-+  ;;     unlikely scenario: if you're running Racket CS, you've
-+  ;;     bootstrapped Chez somehow, so you could use `re.boot`.
-+  ;;  2. A `tpb` or `pb` Racket on a 32-bit platform would still return
-+  ;;     64 from `(system-type 'word)`, but, in addition to the above,
-+  ;;     it is not currently possible or desired to build Racket as
-+  ;;     `tpb` or `pb` (as opposed to pbarch variants):
-+  ;;     see <https://github.com/racket/racket/issues/4692>.
-+  ;;  3. On a hypothetical platform where Chez supported both the
-+  ;;     architecture and the OS, but not the combination of the two,
-+  ;;     (e.g. riscv64 Windows) this code would currently return a
-+  ;;     non-existent native machine (e.g. trv64nt) instead of a
-+  ;;     working pbarch machine. Presumably this could be fixed if
-+  ;;     such a platform came into existence.
-+  (define s (path->string (system-library-subpath #f)))
-+  (define arch+os
-+    (cond
-+      [(regexp-match #rx"^([^\\]+)\\\\([^\\]+)$" s)
-+       => (λ (m)
-+            (reverse (cdr m)))]
-+      [(regexp-match #rx"^([^-]+)-(.+)$" s)
-+       => cdr]
-+      [else
-+       (error 'infer-target-machine "unknown format for system library subpath"
-+              "produced" (system-library-subpath #f))]))
-+  (define arch
-+    (case (car arch+os)
-+      [("x86_64" "amd64") "a6"] ; https://github.com/racket/racket/issues/4691
-+      [("i386") "i3"]
-+      [("aarch64") "arm64"]
-+      [("arm") "arm32"]
-+      [("ppc") "ppc32"]
-+      [("riscv64") "rv64"]
-+      [("unknown") #f] ; pb machine types
-+      [else #f]))
-+  (define os
-+    (case (cadr arch+os)
-+      [("macosx" "darwin" "ios") "osx"]
-+      [("win32" "cygwin") "nt"]
-+      [("linux" "android") "le"]
-+      [("gnu-hurd") "gnu"]
-+      [("freebsd") "fb"]
-+      [("openbsd") "ob"]
-+      [("netbsd") "nb"]
-+      [("solaris") "s2"] ; NOT "sunos4" (I think)
-+      [("qnx") "qnx"]
-+      [("unknown") #f] ; pb machine types
-+      [else #f]))
-+  (if (and arch os)
-+      (string-append "t" arch os)
-+      (format "tpb~a~a"
-+              (system-type 'word)
-+              (if (system-big-endian?)
-+                  "b"
-+                  "l"))))
-+
- (define target-machine (or (hash-ref ht 'make-boot-targate-machine #f)
-                            (getenv "MACH")
--                           (case (system-type)
--                             [(macosx) (if (eqv? 64 (system-type 'word))
--                                           "ta6osx"
--                                           "ti3osx")]
--                             [(windows) (if (eqv? 64 (system-type 'word))
--                                           "ta6nt"
--                                           "ti3nt")]
--                             [else
--                              (case (path->string (system-library-subpath #f))
--                                [("x86_64-linux") "ta6le"]
--                                [("i386-linux") "ti3le"]
--                                [else #f])])))
-+                           (infer-target-machine)))
- (hash-set! ht 'make-boot-targate-machine target-machine)
- 
- (define optimize-level-init 3)
--- 
-2.41.0
-
diff --git a/gnu/packages/patches/racket-backport-8.11-layered-docs.patch b/gnu/packages/patches/racket-backport-8.11-layered-docs.patch
new file mode 100644
index 0000000000..07f105bb24
--- /dev/null
+++ b/gnu/packages/patches/racket-backport-8.11-layered-docs.patch
@@ -0,0 +1,36 @@
+From 1d8dbdf408db9e99f1382323477561d5148cd451 Mon Sep 17 00:00:00 2001
+From: Philip McGrath <philip@philipmcgrath.com>
+Date: Fri, 20 Oct 2023 17:19:50 -0400
+Subject: [PATCH] racket-index: fix release.scrbl for layered installations
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Configure the release notes page to be rendered separately at every
+installation layer. Otherwise, rendering documentation for packages
+installed in a new layer might try to write to `release/in.sxref`
+in the parent layer’s docs directory.
+
+Related to https://github.com/videolang/video/issues/67
+Related to https://issues.guix.gnu.org/56534
+
+(cherry picked from commit 85f21854c0a41564b755fbe180fe6b85de6c4730)
+---
+ pkgs/racket-index/scribblings/main/info.rkt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pkgs/racket-index/scribblings/main/info.rkt b/pkgs/racket-index/scribblings/main/info.rkt
+index 75c507848a..a6a3798f7c 100644
+--- a/pkgs/racket-index/scribblings/main/info.rkt
++++ b/pkgs/racket-index/scribblings/main/info.rkt
+@@ -6,4 +6,4 @@
+     ("local-redirect.scrbl" (depends-all-main no-depend-on every-main-layer) (omit) "local-redirect" 1 10)
+     ("license.scrbl" () (omit))
+     ("acks.scrbl"    () (omit))
+-    ("release.scrbl" (depends-all-main no-depend-on) (omit))))
++    ("release.scrbl" (depends-all-main no-depend-on every-main-layer) (omit))))
+
+base-commit: c3a502c0ae9f4d615bfd85fc7d88b781826bbb09
+-- 
+2.41.0
+