summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-10-17 17:25:48 +0100
committerMathieu Othacehe <othacehe@gnu.org>2023-10-25 11:59:58 +0200
commit1e5ec9d853b89f6a142a4128e9fff6e2d48213d5 (patch)
tree6ab08fb1f78d2eabfefade9ec8b963ca3effeb6e /gnu/packages/patches
parenta0060934a5d7c0bfe81652b31fded150a0ed8e3d (diff)
downloadguix-1e5ec9d853b89f6a142a4128e9fff6e2d48213d5.tar.gz
gnu: hplip: Fix USB timeouts.
* gnu/packages/patches/hplip-usb-timeout.patch: New file.
* gnu/local.mk: Register it.
* gnu/packages/cups.scm (hplip): Use it.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/hplip-usb-timeout.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/patches/hplip-usb-timeout.patch b/gnu/packages/patches/hplip-usb-timeout.patch
new file mode 100644
index 0000000000..b98ed1cc78
--- /dev/null
+++ b/gnu/packages/patches/hplip-usb-timeout.patch
@@ -0,0 +1,24 @@
+# Source: <https://bugs.launchpad.net/hplip/+bug/1922404>
+
+--- a/config_usb_printer.py
++++ b/config_usb_printer.py
+@@ -28,6 +28,7 @@
+ # Std Lib
+ import sys
+ import os
++import time
+ 
+ # Local
+ from base.g import *
+@@ -181,9 +182,10 @@
+        # ******************************* RUNNING FIRMWARE DOWNLOAD TO DEVICE FOR SUPPORTED PRINTER'S
+        fw_download_req = mq.get('fw-download', False)
+        if fw_download_req:
+-           fw_cmd = "hp-firmware -y3 -s %s"%param
++           fw_cmd = "hp-firmware -n -y3 -s %s"%param
+            log.info(fw_cmd)
+            fw_sts, fw_out = utils.run(fw_cmd)
++           time.sleep(5)
+            if fw_sts == 0:
+                log.debug("Firmware downloaded to %s "%device_uri)
+            else: