summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-07-24 10:18:14 +0200
committerLudovic Courtès <ludo@gnu.org>2018-07-24 15:48:06 +0200
commit68f50cfdd34670f7cbc922398e9117de27f964c9 (patch)
tree5868a51c492d57563e3acab1f69ed9edb8ad3c69 /gnu/packages/patches
parente97454b62c3e6fac93441973a9c412d375e17497 (diff)
downloadguix-68f50cfdd34670f7cbc922398e9117de27f964c9.tar.gz
gnu: xorg-server: Apply patch to fix screen rotation on KMS.
Fixes <https://bugs.freedesktop.org/show_bug.cgi?id=106715>.

* gnu/packages/patches/xorg-server-rotate-fb.patch: New file.
* gnu/packages/xorg.scm (xorg-server)[source]: Use it.
* gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/xorg-server-rotate-fb.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/patches/xorg-server-rotate-fb.patch b/gnu/packages/patches/xorg-server-rotate-fb.patch
new file mode 100644
index 0000000000..f47036b2a7
--- /dev/null
+++ b/gnu/packages/patches/xorg-server-rotate-fb.patch
@@ -0,0 +1,35 @@
+commit a85e94a50c94b07574c8701a3ff3c1243f4257f4
+Author: Olivier Fourdan <ofourdan@redhat.com>
+Date:   Fri Jun 15 08:57:12 2018 +0200
+
+    modesetting: use drmmode_bo_import() for rotate_fb
+    
+    drmmode_shadow_allocate() still uses drmModeAddFB() which may fail if
+    the format is not as expected, preventing from using a rotated output.
+    
+    Change it to use the new function drmmode_bo_import() which takes care
+    of calling the drmModeAddFB2() API.
+    
+    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=106715
+    Signed-off-by: Olivier Fourdan <ofourdan@redhat.com>
+    Tested-by: Tomas Pelka <tpelka@redhat.com>
+    Reviewed-by: Lyude Paul <lyude@redhat.com>
+
+diff --git a/hw/xfree86/drivers/modesetting/drmmode_display.c b/hw/xfree86/drivers/modesetting/drmmode_display.c
+index 859a21a9d..ec11b3f56 100644
+--- a/hw/xfree86/drivers/modesetting/drmmode_display.c
++++ b/hw/xfree86/drivers/modesetting/drmmode_display.c
+@@ -1794,11 +1794,8 @@ drmmode_shadow_allocate(xf86CrtcPtr crtc, int width, int height)
+         return NULL;
+     }
+ 
+-    ret = drmModeAddFB(drmmode->fd, width, height, crtc->scrn->depth,
+-                       drmmode->kbpp,
+-                       drmmode_bo_get_pitch(&drmmode_crtc->rotate_bo),
+-                       drmmode_bo_get_handle(&drmmode_crtc->rotate_bo),
+-                       &drmmode_crtc->rotate_fb_id);
++    ret = drmmode_bo_import(drmmode, &drmmode_crtc->rotate_bo,
++                            &drmmode_crtc->rotate_fb_id);
+ 
+     if (ret) {
+         ErrorF("failed to add rotate fb\n");