summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-01-18 19:35:03 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-01-18 20:10:30 +0100
commitaf47145e995c9d3d116a60053648b4f35e2ed125 (patch)
tree6b1fd489b6b1f95985b2b184ed4a7ffaf6502924 /gnu/packages/patches
parentea0e8022f2dfe2d695c859b2038171a0fc4862f9 (diff)
downloadguix-af47145e995c9d3d116a60053648b4f35e2ed125.tar.gz
gnu: python-piexif: Fix patch.
Line-endings in the patch need to be CRLF to meet the patched file's content.

* gnu/packages/patches/python-piexif-fix-tests-with-pillow-7.2.patch:
  Change line-endings of patched lines.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-piexif-fix-tests-with-pillow-7.2.patch48
1 files changed, 24 insertions, 24 deletions
diff --git a/gnu/packages/patches/python-piexif-fix-tests-with-pillow-7.2.patch b/gnu/packages/patches/python-piexif-fix-tests-with-pillow-7.2.patch
index caa2c47c08..874264dc25 100644
--- a/gnu/packages/patches/python-piexif-fix-tests-with-pillow-7.2.patch
+++ b/gnu/packages/patches/python-piexif-fix-tests-with-pillow-7.2.patch
@@ -15,30 +15,30 @@ index 5d105de..a7cad54 100644
 ***************
 *** 9,14 ****
 --- 9,15 ----
-  import time
-  import unittest
-  
-+ import PIL
-  from PIL import Image
-  import piexif
-  from piexif import _common, ImageIFD, ExifIFD, GPSIFD, TAGS, InvalidImageDataError
+  import time

+  import unittest

+  

++ import PIL

+  from PIL import Image

+  import piexif

+  from piexif import _common, ImageIFD, ExifIFD, GPSIFD, TAGS, InvalidImageDataError

 ***************
 *** 580,585 ****
 --- 581,597 ----
-  # test utility methods----------------------------------------------
-  
-      def _compare_value(self, v1, v2):
-+         if isinstance(v2, PIL.TiffImagePlugin.IFDRational):
-+             v2 = (v2.numerator, v2.denominator)
-+         if isinstance(v2, tuple):
-+             converted_v2 = []
-+             for el in v2:
-+                 if isinstance(el, PIL.TiffImagePlugin.IFDRational):
-+                     converted_v2.append((el.numerator, el.denominator))
-+                 else:
-+                     converted_v2.append(el)
-+             v2 = tuple(converted_v2)
-+ 
-          if type(v1) != type(v2):
-              if isinstance(v1, tuple):
-                  self.assertEqual(pack_byte(*v1), v2)
+  # test utility methods----------------------------------------------

+  

+      def _compare_value(self, v1, v2):

++         if isinstance(v2, PIL.TiffImagePlugin.IFDRational):

++             v2 = (v2.numerator, v2.denominator)

++         if isinstance(v2, tuple):

++             converted_v2 = []

++             for el in v2:

++                 if isinstance(el, PIL.TiffImagePlugin.IFDRational):

++                     converted_v2.append((el.numerator, el.denominator))

++                 else:

++                     converted_v2.append(el)

++             v2 = tuple(converted_v2)

++ 

+          if type(v1) != type(v2):

+              if isinstance(v1, tuple):

+                  self.assertEqual(pack_byte(*v1), v2)