summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-06 15:51:44 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-08 00:41:07 -0500
commitb0f92620d8251746ddbcfc443707d72d48fd5af7 (patch)
tree8d2ea179c554df09f42fda59459bdb7d5824c9d1 /gnu/packages/patches
parentd163a379b9dbb57d1f249bf869cff9f535137687 (diff)
downloadguix-b0f92620d8251746ddbcfc443707d72d48fd5af7.tar.gz
gnu: ruby-sanitize: Update to 6.0.0.
* gnu/packages/ruby.scm (ruby-sanitize): Update to 6.0.0.  Re-indent inputs.
[source]: Delete patch.
* gnu/packages/patches/ruby-sanitize-system-libxml.patch: Delete patch.
* gnu/local.mk (dist_patch_DATA): De-register it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/ruby-sanitize-system-libxml.patch38
1 files changed, 0 insertions, 38 deletions
diff --git a/gnu/packages/patches/ruby-sanitize-system-libxml.patch b/gnu/packages/patches/ruby-sanitize-system-libxml.patch
deleted file mode 100644
index d19eb07294..0000000000
--- a/gnu/packages/patches/ruby-sanitize-system-libxml.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-Fix test failures that occur when nokogiri is using system libxml:
-
-  https://github.com/rgrove/sanitize/issues/198
-
-Taken from upstream:
-https://github.com/rgrove/sanitize/commit/21da9b62baf9ea659811d92e6b574130aee57eba
-
-diff --git a/test/test_malicious_html.rb b/test/test_malicious_html.rb
-index 2c23074..0756de0 100644
---- a/test/test_malicious_html.rb
-+++ b/test/test_malicious_html.rb
-@@ -135,6 +135,8 @@
-   # The relevant libxml2 code is here:
-   # <https://github.com/GNOME/libxml2/commit/960f0e275616cadc29671a218d7fb9b69eb35588>
-   describe 'unsafe libxml2 server-side includes in attributes' do
-+    using_unpatched_libxml2 = Nokogiri::VersionInfo.instance.libxml2_using_system?
-+
-     tag_configs = [
-       {
-         tag_name: 'a',
-@@ -166,6 +168,8 @@
-         input = %[<#{tag_name} #{attr_name}='examp<!--" onmouseover=alert(1)>-->le.com'>foo</#{tag_name}>]
- 
-         it 'should escape unsafe characters in attributes' do
-+          skip "behavior should only exist in nokogiri's patched libxml" if using_unpatched_libxml2
-+
-           # This uses Nokogumbo's HTML-compliant serializer rather than
-           # libxml2's.
-           @s.fragment(input).
-@@ -191,6 +195,8 @@
-         input = %[<#{tag_name} #{attr_name}='examp<!--" onmouseover=alert(1)>-->le.com'>foo</#{tag_name}>]
- 
-         it 'should not escape characters unnecessarily' do
-+          skip "behavior should only exist in nokogiri's patched libxml" if using_unpatched_libxml2
-+
-           # This uses Nokogumbo's HTML-compliant serializer rather than
-           # libxml2's.
-           @s.fragment(input).