summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorAhmad Draidi <a.r.draidi@redscript.org>2024-02-04 17:54:42 +0400
committerJohn Kehayias <john.kehayias@protonmail.com>2024-02-19 22:19:44 -0500
commitb4148713d18c4b6c37639653de5191eb7f1ca4cc (patch)
tree5fd6c538b036ec9a416382f56268aaa066f8b975 /gnu/packages/patches
parent193a01d73f002642bae8a5a4f9a68a089f66ffe4 (diff)
downloadguix-b4148713d18c4b6c37639653de5191eb7f1ca4cc.tar.gz
gnu: Update wlroots to 0.17.1.
Keep the older version as wlroots-0.16 since a few packages break without it.

* gnu/packages/wm.scm (wlroots): Update to 0.17.1.
[source]: Add patch.
[propagated-inputs]: Add libdisplay-info.
* gnu/packages/patches/wlroots-hwdata-fallback.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/wm.scm (wlroots-0.16): New variable.
* gnu/packages/wm.scm (cage)[inputs]: Replace wlroots with wlroots-0.16.
* gnu/packages/wm.scm (fnott)[inputs]: Likewise.
* gnu/packages/wm.scm (dwl)[inputs]: Likewise.
* gnu/packages/wm.scm (sway)[inputs]: Likewise.
* gnu/packages/wm.scm (cagebreak)[inputs]: Likewise.
* gnu/packages/wm.scm (hikari)[inputs]: Likewise.
* gnu/packages/wm.scm (river)[native-inputs]: Likewise.

Change-Id: Ib3d3938d6486fb1674380811a6dc0a512c991ac7
Signed-off-by: John Kehayias <john.kehayias@protonmail.com>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/wlroots-hwdata-fallback.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/patches/wlroots-hwdata-fallback.patch b/gnu/packages/patches/wlroots-hwdata-fallback.patch
new file mode 100644
index 0000000000..6468c7cbf3
--- /dev/null
+++ b/gnu/packages/patches/wlroots-hwdata-fallback.patch
@@ -0,0 +1,46 @@
+backend/drm: add hardcoded hwdata path fallback
+
+Add hardcoded fallback "/usr/share/hwdata/pnp.ids" as a
+temporary solution to get things working in Guix until
+hwdata ships with pkg-config file.
+
+diff --git a/backend/drm/meson.build b/backend/drm/meson.build
+index 6fcb2c15..ed95360a 100644
+--- a/backend/drm/meson.build
++++ b/backend/drm/meson.build
+@@ -1,8 +1,7 @@
+ hwdata = dependency(
+ 	'hwdata',
+-	required: 'drm' in backends,
++	required: false,
+ 	native: true,
+-	not_found_message: 'Required for the DRM backend.',
+ )
+ 
+ libdisplay_info = dependency(
+@@ -19,15 +18,21 @@ libliftoff = dependency(
+ 	required: false,
+ )
+ 
+-if not (hwdata.found() and libdisplay_info.found() and features['session'])
++if hwdata.found()
++	hwdata_dir = hwdata.get_variable(pkgconfig: 'pkgdatadir')
++	pnp_ids = files(hwdata_dir / 'pnp.ids')
++else
++	pnp_ids = files('/usr/share/hwdata/pnp.ids')
++endif
++
++if not (libdisplay_info.found() and features['session'])
+ 	subdir_done()
+ endif
+ 
+-hwdata_dir = hwdata.get_variable(pkgconfig: 'pkgdatadir')
+ pnpids_c = custom_target(
+ 	'pnpids.c',
+ 	output: 'pnpids.c',
+-	input: files(hwdata_dir / 'pnp.ids'),
++	input: pnp_ids,
+ 	feed: true,
+ 	capture: true,
+ 	command: files('gen_pnpids.sh'),
+