summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-10-22 23:07:16 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-10-22 23:07:16 +0200
commitc166a88dea354f0fb253e7d389e68f1b11fe1de4 (patch)
tree24719ff7ec1053c7e997afb10fe3a9bc276efddf /gnu/packages/patches
parentffddb42d6c510456997ee6de1c1b8026c9ce6d14 (diff)
parent63abd1e2a36d48e1f8f7057a4c844b9cf5733be7 (diff)
downloadguix-c166a88dea354f0fb253e7d389e68f1b11fe1de4.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/crossmap-allow-system-pysam.patch121
-rw-r--r--gnu/packages/patches/delly-use-system-libraries.patch56
-rw-r--r--gnu/packages/patches/liblxqt-include.patch14
-rw-r--r--gnu/packages/patches/tophat-build-with-later-seqan.patch24
4 files changed, 0 insertions, 215 deletions
diff --git a/gnu/packages/patches/crossmap-allow-system-pysam.patch b/gnu/packages/patches/crossmap-allow-system-pysam.patch
deleted file mode 100644
index 611c4ff74d..0000000000
--- a/gnu/packages/patches/crossmap-allow-system-pysam.patch
+++ /dev/null
@@ -1,121 +0,0 @@
-This patch modifies the build process such that the bundled copy of pysam does
-not need to be built if CROSSMAP_USE_SYSTEM_PYSAM is set and the pysam module
-can be imported.
-
-Upstream has agreed to apply the patch in the next maintenance release of
-crossmap.  The patch has already been uploaded to
-http://sourceforge.net/projects/crossmap/files/patch/.
-
-diff --git a/setup.py b/setup.py
---- a/setup.py	2015-02-26 15:28:49.771189185 +0100
-+++ b/setup.py	2015-02-26 15:55:03.440327752 +0100
-@@ -19,6 +19,15 @@
- except:
- 	have_numpy = False
- 
-+try:
-+	import pysam
-+	if os.environ['CROSSMAP_USE_SYSTEM_PYSAM']:
-+		have_pysam = True
-+	else:
-+		have_pysam = False
-+except ImportError:
-+	have_pysam = False
-+
- if platform.system()=='Windows':
- 	print >> sys.stderr, "Sorry, Windows platform is not supported!"
- 	sys.exit()
-@@ -165,49 +174,50 @@
- 	
- 	
- 	#================= pysam samtools ====================
--	extensions.append(Extension(
--    	"pysam.csamtools",              
--		csamtools_sources + [ "lib/pysam/%s" % x for x in ("pysam_util.c", )] +\
--		glob.glob( os.path.join( "lib/samtools", "*.pysam.c" )) +\
--		os_c_files + \
--		glob.glob( os.path.join( "lib/samtools", "*", "*.pysam.c" ) ),
--		library_dirs=[],
--		include_dirs=[ "lib/samtools", "lib/pysam" ] + include_os,
--		libraries=[ "z", ],
--		language="c",
--		define_macros = [('_FILE_OFFSET_BITS','64'),('_USE_KNETFILE','')], 
--    ))
--
--	extensions.append(Extension(
--		"pysam.ctabix",                   
--		tabix_sources + [ "lib/pysam/%s" % x for x in ( "tabix_util.c", )] +\
--		os_c_files + \
--		glob.glob( os.path.join( "lib/tabix", "*.pysam.c" ) ),
--		library_dirs=[],
--		include_dirs=[ "lib/tabix", "lib/pysam" ] + include_os,
--		libraries=[ "z", ],
--		language="c",
--		define_macros = [('_FILE_OFFSET_BITS','64'),
--                     ('_USE_KNETFILE','')], 
--    ))
--
--	extensions.append(Extension(
--		"pysam.TabProxies",               
--		tabproxies_sources + os_c_files,
--		library_dirs=[],
--		include_dirs= include_os,
--		libraries=[ "z", ],
--		language="c",
--    ))
--
--	extensions.append(Extension(
--		"pysam.cvcf",                   
--		cvcf_sources + os_c_files,
--		library_dirs=[],
--		include_dirs= ["lib/tabix",] + include_os,
--		libraries=[ "z", ],
--		language="c",
--    ))
-+        if not have_pysam:
-+                extensions.append(Extension(
-+                        "pysam.csamtools",              
-+                        csamtools_sources + [ "lib/pysam/%s" % x for x in ("pysam_util.c", )] +\
-+                        glob.glob( os.path.join( "lib/samtools", "*.pysam.c" )) +\
-+                        os_c_files + \
-+                        glob.glob( os.path.join( "lib/samtools", "*", "*.pysam.c" ) ),
-+                        library_dirs=[],
-+                        include_dirs=[ "lib/samtools", "lib/pysam" ] + include_os,
-+                        libraries=[ "z", ],
-+                        language="c",
-+                        define_macros = [('_FILE_OFFSET_BITS','64'),('_USE_KNETFILE','')], 
-+                ))
-+
-+                extensions.append(Extension(
-+                        "pysam.ctabix",                   
-+                        tabix_sources + [ "lib/pysam/%s" % x for x in ( "tabix_util.c", )] +\
-+                        os_c_files + \
-+                        glob.glob( os.path.join( "lib/tabix", "*.pysam.c" ) ),
-+                        library_dirs=[],
-+                        include_dirs=[ "lib/tabix", "lib/pysam" ] + include_os,
-+                        libraries=[ "z", ],
-+                        language="c",
-+                        define_macros = [('_FILE_OFFSET_BITS','64'),
-+                                         ('_USE_KNETFILE','')], 
-+                ))
-+
-+                extensions.append(Extension(
-+                        "pysam.TabProxies",               
-+                        tabproxies_sources + os_c_files,
-+                        library_dirs=[],
-+                        include_dirs= include_os,
-+                        libraries=[ "z", ],
-+                        language="c",
-+                ))
-+
-+                extensions.append(Extension(
-+                        "pysam.cvcf",                   
-+                        cvcf_sources + os_c_files,
-+                        library_dirs=[],
-+                        include_dirs= ["lib/tabix",] + include_os,
-+                        libraries=[ "z", ],
-+                        language="c",
-+                ))
- 
- 
- 	return extensions     
diff --git a/gnu/packages/patches/delly-use-system-libraries.patch b/gnu/packages/patches/delly-use-system-libraries.patch
deleted file mode 100644
index 3315c2a176..0000000000
--- a/gnu/packages/patches/delly-use-system-libraries.patch
+++ /dev/null
@@ -1,56 +0,0 @@
---- a/Makefile	2017-04-09 12:48:15.000000000 +0200
-+++ b/Makefile	2017-06-21 14:26:02.749282787 +0200
-@@ -9,8 +9,8 @@
- 
- # Flags
- CXX=g++
--CXXFLAGS += -isystem ${SEQTK_ROOT} -isystem ${BOOST_ROOT} -pedantic -W -Wall -Wno-unknown-pragmas -D__STDC_LIMIT_MACROS -fno-strict-aliasing
--LDFLAGS += -L${SEQTK_ROOT} -L${BOOST_ROOT}/stage/lib -lboost_iostreams -lboost_filesystem -lboost_system -lboost_program_options -lboost_date_time 
-+CXXFLAGS += -pedantic -W -Wall -Wno-unknown-pragmas -D__STDC_LIMIT_MACROS -fno-strict-aliasing
-+LDFLAGS += -lboost_iostreams -lboost_filesystem -lboost_system -lboost_program_options -lboost_date_time 
- 
- # Additional flags for release/debug
- ifeq (${PARALLEL}, 1)
-@@ -23,7 +23,7 @@
- ifeq (${STATIC}, 1)
- 	LDFLAGS += -static -static-libgcc -pthread -lhts -lz
- else
--	LDFLAGS += -lhts -lz -Wl,-rpath,${SEQTK_ROOT},-rpath,${BOOST_ROOT}/stage/lib
-+	LDFLAGS += -lhts -lz
- endif
- ifeq (${DEBUG}, 1)
- 	CXXFLAGS += -g -O0 -fno-inline -DDEBUG
-@@ -41,29 +41,17 @@
- DELLYSOURCES = $(wildcard src/*.h) $(wildcard src/*.cpp)
- 
- # Targets
--TARGETS = .htslib .bcftools .boost src/delly src/cov src/dpe
-+TARGETS = src/delly src/cov src/dpe
- 
- all:   	$(TARGETS)
- 
--.htslib: $(HTSLIBSOURCES)
--	cd src/htslib && make && make lib-static && cd ../../ && touch .htslib
--
--.bcftools: $(HTSLIBSOURCES)
--	cd src/bcftools && make && cd ../../ && touch .bcftools
--
--.boost: $(BOOSTSOURCES)
--	cd src/modular-boost && ./bootstrap.sh --prefix=${PWD}/src/modular-boost --without-icu --with-libraries=iostreams,filesystem,system,program_options,date_time && ./b2 && ./b2 headers && cd ../../ && touch .boost
--
--src/delly: .htslib .bcftools .boost $(DELLYSOURCES)
--	$(CXX) $(CXXFLAGS) $@.cpp -o $@ $(LDFLAGS)
--
--src/cov: .htslib .bcftools .boost $(DELLYSOURCES)
-+src/cov: $(DELLYSOURCES)
- 	$(CXX) $(CXXFLAGS) $@.cpp -o $@ $(LDFLAGS)
- 
--src/dpe: .htslib .bcftools .boost $(DELLYSOURCES)
-+src/dpe: $(DELLYSOURCES)
- 	$(CXX) $(CXXFLAGS) $@.cpp -o $@ $(LDFLAGS)
- 
- clean:
- 	cd src/htslib && make clean
- 	cd src/modular-boost && ./b2 --clean-all
--	rm -f $(TARGETS) $(TARGETS:=.o) .htslib .boost .bcftools
-+	rm -f $(TARGETS) $(TARGETS:=.o)
diff --git a/gnu/packages/patches/liblxqt-include.patch b/gnu/packages/patches/liblxqt-include.patch
deleted file mode 100644
index 4e8cf04789..0000000000
--- a/gnu/packages/patches/liblxqt-include.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Patch to fix build with Qt 5.5, taken from upstream:
-   https://github.com/lxde/liblxqt/commit/7303ea207de0771d6f450a31ec4a1ce69202869b
-
-diff -u -r liblxqt-0.9.0.orig/lxqtnotification.h liblxqt-0.9.0/lxqtnotification.h
---- liblxqt-0.9.0.orig/lxqtnotification.h	2015-07-27 22:49:05.365166482 +0200
-+++ liblxqt-0.9.0/lxqtnotification.h	2015-07-27 22:49:36.897606619 +0200
-@@ -25,6 +25,7 @@
- #ifndef LXQTNOTIFICATION_H
- #define LXQTNOTIFICATION_H
- 
-+#include <QObject>
- #include <QStringList>
- #include "lxqtglobals.h"
- 
diff --git a/gnu/packages/patches/tophat-build-with-later-seqan.patch b/gnu/packages/patches/tophat-build-with-later-seqan.patch
deleted file mode 100644
index fc742e2a7d..0000000000
--- a/gnu/packages/patches/tophat-build-with-later-seqan.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-This patch resolves a build failure when building TopHat 2.1.0 with SeqAn 1.4.
-This is the relevant part of a patch originally posted here:
-https://lists.fu-berlin.de/pipermail/seqan-dev/2014-July/msg00001.html
-
---- a/src/segment_juncs.cpp
-+++ b/src/segment_juncs.cpp
-@@ -2050,10 +2050,13 @@ void juncs_from_ref_segs(RefSequenceTabl
-     typedef map<uint32_t, IntronMotifs> MotifMap;
-     
-     MotifMap ims;
--	
--    seqan::DnaStringReverseComplement rev_donor_dinuc(donor_dinuc);
--    seqan::DnaStringReverseComplement rev_acceptor_dinuc(acceptor_dinuc);
--    
-+
-+    typedef seqan::ModifiedString<
-+                    seqan::ModifiedString<seqan::DnaString const, seqan::ModView<seqan::FunctorComplement<seqan::Dna> > >,  
-+                    seqan::ModReverse>   ConstDnaStringReverseComplement;
-+    ConstDnaStringReverseComplement rev_donor_dinuc(donor_dinuc);
-+    ConstDnaStringReverseComplement rev_acceptor_dinuc(acceptor_dinuc);
-+     
-     if (talkative)
-         fprintf(stderr, "Collecting potential splice sites in islands\n");
-