summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-01-15 01:00:01 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2023-01-15 01:00:00 +0100
commitec3226c3985d5ec168d45499f12dfcf87f0f5c94 (patch)
tree764a5906bed626737fd5b59066cd3ac0393fb3c1 /gnu/packages/patches
parentea37595a7c71a430b0d1a2c860b9b0e37ec126bd (diff)
downloadguix-ec3226c3985d5ec168d45499f12dfcf87f0f5c94.tar.gz
gnu: lirc: Update to 0.10.2.
* gnu/packages/lirc.scm (lirc): Update to 0.10.2.
[arguments]: Add a new 'build-reproducibly phase to partially replace…
* gnu/packages/patches/lirc-reproducible-build.patch: …this updated file.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/lirc-reproducible-build.patch69
1 files changed, 16 insertions, 53 deletions
diff --git a/gnu/packages/patches/lirc-reproducible-build.patch b/gnu/packages/patches/lirc-reproducible-build.patch
index 20f9344715..75aa480941 100644
--- a/gnu/packages/patches/lirc-reproducible-build.patch
+++ b/gnu/packages/patches/lirc-reproducible-build.patch
@@ -5,11 +5,22 @@ https://sourceforge.net/p/lirc/git/merge-requests/33/
 https://sourceforge.net/p/lirc/git/merge-requests/34/
 https://sourceforge.net/p/lirc/git/merge-requests/36/
 
-Index: lirc-0.10.1/tools/lirc-lsplugins.cpp
-===================================================================
---- lirc-0.10.1.orig/tools/lirc-lsplugins.cpp
-+++ lirc-0.10.1/tools/lirc-lsplugins.cpp
-@@ -415,10 +415,9 @@ static void print_header(void)
+diff -Naur lirc-0.10.2a/python-pkg/lirc/database.py lirc-0.10.2/python-pkg/lirc/database.py
+--- lirc-0.10.2a/python-pkg/lirc/database.py	1970-01-01 01:00:01.000000000 +0100
++++ lirc-0.10.2/python-pkg/lirc/database.py	2023-01-20 14:23:29.414088668 +0100
+@@ -160,7 +160,7 @@
+             d['device_hint'] = hint
+ 
+         configs = {}
+-        for path in glob.glob(configdir + '/*.conf'):
++        for path in sorted(glob.glob(configdir + '/*.conf')):
+             with open(path) as f:
+                 cf = yaml.load(f.read(), Loader = Loader)
+             configs[cf['config']['id']] = cf['config']
+diff -Naur lirc-0.10.2a/tools/lirc-lsplugins.cpp lirc-0.10.2/tools/lirc-lsplugins.cpp
+--- lirc-0.10.2a/tools/lirc-lsplugins.cpp	1970-01-01 01:00:01.000000000 +0100
++++ lirc-0.10.2/tools/lirc-lsplugins.cpp	2023-01-20 14:24:42.719085612 +0100
+@@ -413,10 +413,9 @@
  static void print_yaml_header(void)
  {
  	static const char* const YAML_HEADER =
@@ -22,51 +33,3 @@ Index: lirc-0.10.1/tools/lirc-lsplugins.cpp
  	printf("\ndrivers:\n");
  }
  
-Index: lirc-0.10.1/python-pkg/lirc/database.py
-===================================================================
---- lirc-0.10.1.orig/python-pkg/lirc/database.py
-+++ lirc-0.10.1/python-pkg/lirc/database.py
-@@ -156,7 +156,7 @@ class Database(object):
-             d['device_hint'] = hint
- 
-         configs = {}
--        for path in glob.glob(configdir + '/*.conf'):
-+        for path in sorted(glob.glob(configdir + '/*.conf')):
-             with open(path) as f:
-                 cf = yaml.load(f.read())
-             configs[cf['config']['id']] = cf['config']
-Index: lirc-0.10.1/tools/irdb-get
-===================================================================
---- lirc-0.10.1.orig/tools/irdb-get
-+++ lirc-0.10.1/tools/irdb-get
-@@ -9,7 +9,6 @@ import fnmatch
- import os
- import os.path
- import sys
--import time
- import urllib.error          # pylint: disable=no-name-in-module,F0401,E0611
- import urllib.request        # pylint: disable=no-name-in-module,F0401,E0611
- 
-@@ -193,7 +192,7 @@ def do_yaml_config():
-         lircmd_by_driver[driver].append("%s/%s" % (tokens[0], tokens[2]))
- 
-     print("#")
--    print("# Created by 'irdb-get yaml-config' at " + time.ctime())
-+    print("# Created by 'irdb-get yaml-config'")
-     print("#")
-     print("\nlircd_by_driver:")
-     print_yaml_dict(lircd_by_driver)
-Index: lirc-0.10.1/tools/lirc-make-devinput
-===================================================================
---- lirc-0.10.1.orig/tools/lirc-make-devinput
-+++ lirc-0.10.1/tools/lirc-make-devinput
-@@ -61,8 +61,7 @@ if test -n "$lirc_map"; then
- fi
- 
- 
--echo "# Generated by $(basename $0) on $(uname -r)"
--echo "# Date: $(date)"
-+echo "# Generated by $(basename $0)"
- cat <<EOF
- 
- begin remote