summary refs log tree commit diff
path: root/gnu/packages/patchutils.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2018-11-29 22:17:40 -0600
committerEric Bavier <bavier@member.fsf.org>2018-11-30 00:21:25 -0600
commit5f230fb2798e9862fba67228b9de89df8f36e8e0 (patch)
treec552cfc8273a47ec7b09578f32801e2942f35e7b /gnu/packages/patchutils.scm
parent7b05e957fa8adfe2c85d7d164b8a2f4c9796fdb2 (diff)
downloadguix-5f230fb2798e9862fba67228b9de89df8f36e8e0.tar.gz
patchutils: Update to 0.3.4.
* gnu/packages/patchutils.scm (patchutils): Update to 0.3.4.
[arguments]: Simplify 'patch-test-scripts' phase.
* gnu/packages/patches/patchutils-xfail-gendiff-tests.patch: Rename to...
* gnu/packages/patches/patchutils-test-perms.patch: ...this.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/patchutils.scm')
-rw-r--r--gnu/packages/patchutils.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index 688e62cdc8..fa5ad62e44 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -43,7 +43,7 @@
 (define-public patchutils
   (package
     (name "patchutils")
-    (version "0.3.3")
+    (version "0.3.4")
     (source
      (origin
       (method url-fetch)
@@ -51,8 +51,8 @@
                           name "-" version ".tar.xz"))
       (sha256
        (base32
-        "0g5df00cj4nczrmr4k791l7la0sq2wnf8rn981fsrz1f3d2yix4i"))
-      (patches (search-patches "patchutils-xfail-gendiff-tests.patch"))))
+        "0xp8mcfyi5nmb5a2zi5ibmyshxkb1zv1dgmnyn413m7ahgdx8mfg"))
+      (patches (search-patches "patchutils-test-perms.patch"))))
     (build-system gnu-build-system)
     (inputs `(("perl" ,perl)))
     (arguments
@@ -61,10 +61,8 @@
        (modify-phases %standard-phases
          (add-before 'check 'patch-test-scripts
            (lambda _
-             (let ((echo (which "echo")))
-               (substitute*
-                   (find-files "tests" "^run-test$")
-                 (("/bin/echo") echo)))
+             (substitute* (find-files "tests" "^run-test$")
+               (("/bin/echo") (which "echo")))
              #t))
          (add-after 'install 'wrap-program
            ;; Point installed scripts to the utilities they need.